none
Yammer Embed Feed Issue RRS feed

  • Question

  • Hi all, 

    I have a Yammer feed embedded in to a page layout and this has been working fine up until the last two days, we are now finding that the Yammer feed displaying a "404 Not Found, nginx" error. The weird thing is this only appears to be occurring for certain users. Some users are experiencing the error in Internet Explorer whilst saying it was works fine in Google Chrome whilst others are reporting that the issue does not work in any browser, I have been able to replicate this in a different tenant also and I am currently finding that is mainly occurs for me if I am using in private prowsing/incognito 

    This is the error I am getting:

    I am finding that in the console I am also seeing an error, it is saying that it is not finding the below url:

    https://www.yammer.com/embed-feed?container=%23embedded-feed&network=https%3A%2F%2Fwww.yammer.com%2Fmytentant.com&config%5Bheader%5D=true&config%5Bfooter%5D=true&config%5BpromptText%5D=&feedType=my&network_permalink=https%3A%2F%2Fwww.yammer.com%2Fmytenant.com&bust=1462348860770

    Any help with this would be greatly appreciated. 

    Wednesday, May 4, 2016 8:15 AM

Answers

  • It has been acknowledged as a bug here:

    https://community.office365.com/en-us/f/176/t/442928

    Due for fix "at the end of the quarter" - whatever that means.  They must do quarterly releases and the last release broke it and the next release fixes it.

    This is not an issue related only to SharePoint - anyone trying to embed a Yammer feed using locales other than English (US) will be affected.  :(

    Interestingly, a lot of Yammer stuff seems to only support en-US, including some of the support pages.


    -- Richard Carde

    • Proposed as answer by Shark69 Friday, May 13, 2016 3:18 PM
    • Marked as answer by Adam13Hylo Sunday, May 15, 2016 3:29 PM
    Wednesday, May 11, 2016 1:24 AM

All replies

  • Hi Adam,

    Per my test, the URL is about a page that contains several Yammer feeds in it.

    I recommend to copy and paste the URL in the browser and then check if you can view the page directly.

    If it still shows page not found, please clear the cache in your browser and then access your Yammer again in SharePoint.

    Best Regards,

    Victoria


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Thursday, May 5, 2016 6:56 AM
    Moderator
  • Hi Victoria,

    I am also unable to access the URL directly in the browser, I have also tried clearing my browser history and emptying the cache however this still did not work.

    Sorry.

    Kind Regards,
    Adam

    Thursday, May 5, 2016 7:38 AM
  • Hi Adam,

    Is there any issue when you access https://www.yammer.com in your browser?

    Could you please also share the code for embedding the Yammer feed in SharePoint page?

    Best Regards,

    Victoria


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, May 5, 2016 8:48 AM
    Moderator
  • Oh no sorry I can access https://yammer.com fine, however if I try to access the url which is being returned in the console then I get the error.

    The code I am using is: 

     <script type="text/javascript" src="https://c64.assets-yammer.com/assets/platform_embed.js"></script>
        <div id="embedded-feed" style="height:400px;width:500px;"></div> 
        <script>
            yam.connect.embedFeed({
                container: '#embedded-feed',
                network: 'myyammefeed.com,
                feedType: 'group',      
                feedId: '8083974'   
            });
        </script>


    Thursday, May 5, 2016 8:52 AM
  • Hi, we are having this identical issue also. Yammer feed will no longer flow through to Sharepoint both in Chrome and IE. 
    Friday, May 6, 2016 5:43 AM
  • We too have started having the problem.

    It seems Yammer's "embed-feed" code is broken if your accept languages doesn't include en-US (who doesn't?  *cough*).

    I presume you are not sending Accept-Language: en-US or not having a Yammer cookie of locale=en-US present (I think).

    If you add English (United States) to IE via Internet Options->Languages it works.  You can then remove that locale from IE as Yammer will have the cookie.  Hope they fix the bug soon!!

    Worked for me.  YMMV.


    -- Richard Carde


    Friday, May 6, 2016 6:44 AM
  • This works oddly enough however it isnt a fix as this means that everyone now gets an American formatted date in the system tray. We also have users all over the world who this fix would not work for :( 
    Friday, May 6, 2016 1:39 PM
  • Changing the language of your system to 'en-US' seems to do the trick aswell as visiting Yammer directly in the browser and then refreshing the page with the embedded feed.

    But does anyone already have a sustainable solution for the users who are not willing to apply english as a language on their system, even for a short while?

    Kind regards,

    Lynn


    Kind regards, Lynn

    Monday, May 9, 2016 11:51 AM
  • Hoping to get some traction over in the Office 365 forum.

    https://community.office365.com/en-us/f/176/t/442928


    -- Richard Carde

    Tuesday, May 10, 2016 12:39 AM
  • I have the same issue here.  We are in the UK and are looking to roll out Yammer as the main company information feed on the company intranet.  However this bug is causing us problems.  I can also confirm the US language change does fix it, but its not a feasible solution to set this on all of our PCs.  Really hoping someone can find a fix soon.
    Tuesday, May 10, 2016 10:14 AM
  • Glad to know I am not the only one experiencing this issue Chris.

    I have raised a ticket with Microsoft through out partner portal and I today received a response letting me know that this is with the development team to fix so hopefully we will see a fix soon.


    Tuesday, May 10, 2016 10:24 AM
  • We have the same issue. Having our 3000 worldwide users switch to EN-US is not an option! We have users from a dozen countries and they can't be expected to keep flipping the language to see a Yammer feed. I can replicate the issue using Windows 7 and IE 11. I have the language set to EN-Canada it is still causes an issue.

    When is Microsoft going to fix this bug? We cannot go ahead with rolling out a PRODUCTION Yammer release with this issue left as is. We seem to have other issues with the embedded Yammer which I will address in another thread. 

    We have found other bugs in the product too and MS seems slow to respond to any issues involving SP 2013. Instead of upgrading as a solution, why not actually fix the problem at hand?

    Thanks,

    Doug F, M.S., ITIL.


    Tuesday, May 10, 2016 6:07 PM
  • It has been acknowledged as a bug here:

    https://community.office365.com/en-us/f/176/t/442928

    Due for fix "at the end of the quarter" - whatever that means.  They must do quarterly releases and the last release broke it and the next release fixes it.

    This is not an issue related only to SharePoint - anyone trying to embed a Yammer feed using locales other than English (US) will be affected.  :(

    Interestingly, a lot of Yammer stuff seems to only support en-US, including some of the support pages.


    -- Richard Carde

    • Proposed as answer by Shark69 Friday, May 13, 2016 3:18 PM
    • Marked as answer by Adam13Hylo Sunday, May 15, 2016 3:29 PM
    Wednesday, May 11, 2016 1:24 AM
  • Thanks!
    Friday, May 13, 2016 3:14 PM
  • Thanks Richard! I have an open ticket with Microsoft on this, I will let you know of any progress.
    Sunday, May 15, 2016 3:29 PM
  • Any news about this?

    We´re using Windows 10 and adding EN-US language to OS (IE´s language option are only link to OS languages) changes the Yammer behavior to 505 error. If EN-US is not added, Yammer stays at "Loading" - state.

    There is another solution to add Protected Mode to IE, but it will mess up our other settings...


    Please remember to mark my post as an answer, if I really helped you out, or vote if usefull. Thank you!

    Monday, February 20, 2017 10:36 AM