none
Requests to install .NET FRAMEWORK 4.0.30319 even though the system is already installed RRS feed

  • Question

  • Dear Gurus!

    I am trying to run the WPF application on the client machine (Windows 7) and  receive messages 

    "You must install Microsoft .NET framework v.4.0.30319" even though the system is already installed

    Microsoft .NET framework v.4.0.30319 Client Profile (38.8 mb) and Microsoft .NET framework v.4.0.30319 Extended (51.9 mb)/

    I use Microsoft Prism 4.1 and all project has target framework 4.0.

    How to fix?

    Wednesday, October 14, 2015 9:40 AM

Answers

  • Hi ATerentjev,

    For your issue, we need to make sure whether the .NET framework is installed correctly, please take the following steps:

    1. Use .NET Framework Setup Verification Tool to verify the .NET Frameworks on your machine, you can download from here: http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    By using it, you will find the log file under %TEMP% folder, see the first 15 lines and the last 15 lines.

    2. If the exit code != 0, it means that your .NET installed incorrectly, please first use .NET Framework Repair Tool to repair it, http://www.microsoft.com/en-us/download/details.aspx?id=30135

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Thursday, October 15, 2015 5:22 AM
    Moderator

All replies