locked
Public IP is not accessible publicly RRS feed

  • Question

  • Hello,

    I created a virtual machine on windows 2008 R2. The system has assigned me a Public IP Address but it is not showing on local area of virtual machine.  How can I host any website in virtual machine using IIS when its IP is not accessible over internet. 

    How to resolve this problem.


    Syed Muhammad Ali

    Thursday, June 28, 2012 11:31 AM

All replies

  • Hi Syed,

    I'm not an expert but did you create a new Endpoint for the port 80 in windows Azure portal.

    Hope is help...

    Thanks


    Architecte de solutions SharePoint 2007/2010 - Site d'aide aux utilisateurs de SharePoint -> http://www.aide-sharepoint.info

    Thursday, June 28, 2012 12:45 PM
  • Hi Syed,

    The virtual IP (VIP) that shows up under Quick Glance for the VM is the external IP, and the dynamic IP (DIP) is the 10. address that is internal to Azure.

    By default, only an RDP endpoint is open to port 3389, but you can open additional endpoints for port 80 for HTTP for example depending on what you want to accomplish.

    To create endpoints, select the Endpoints tab, click Add Endpoint at the bottom, leave it on Add Endpoint, next, then select a friendly display name for Name, for example HTTP, then select the public port and private port, for HTTP for example that could be 80 and 80. But keep in mind the public port must be unique for the cloud service containing the VM, because there is a single public IP per cloud service, but not necessarily per VM. If you do Quick Create to create a VM - that will always have a single VM in a cloud service, but using the gallery create option or via PowerShell you could have multiple VMs behind the same public IP.

    Thanks,

    Craig

    Thursday, June 28, 2012 12:50 PM
  • Got it, and it is working now, but how can I install DNS service in VM when the VM does not have static IP.  I want to host multiple websites using DNS service with websitepanel control panel.

    Another problem I am facing is How to upload content using FTP. I am using Microsoft FTP service and I opened the port 21 but still no access.

    Does anyone has idea about this.

    Thanks in advance


    Syed Muhammad Ali


    Friday, June 29, 2012 6:45 AM
  • Hello I followed the steps to create an end point via the Azure Dashboard, but im getting the following error when its trying to create it:

    Failed to add endpoint http to virtual machine MyVM.

    Windows Azure is currently performing an operation on this deployment that requires exclusive access.

    Browser: 5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; MS-RTC LM 8)

    User language: en-us

    Portal Version: 6.0.6002.18488 (rd_auxportal_stable.120806-1529)

    Subscriptions: c3538333-8e25-4404-b4ab-cdef8b1ff54b

    User email address: *****************

    Any  help would be appreciated.

    Friday, August 24, 2012 6:27 PM
  •  

    I have installed TFS on the server and mapped it port to a end point to access it from outside, until yesterday it worked fine [for 1 day]. but today after I restart the server I cannot connect to the TFS or I cannot browse TFS or any other websites hosted in the server(which are given end points). can you help me to figure this out

    Thanks


    - RVN -

    Tuesday, September 4, 2012 6:38 PM