none
Static Driver Verifier not recognizing driver type (storport) RRS feed

  • Question

  • I'm trying to run static driver verifier from Visual Studio (Community 2015) against my storport miniport.  However, when I try to launch it, I get the following error:

    "Driver type is 'wdf_storport_wdf'.  This driver type is not supported by SDV.  Please consult the documentation for supported driver types."  Where does sdv look to determine the driver type?  I have run the Code Analysis tool and ensured that there are no warnings or errors in my code before launching SDV so I'm pretty sure that's not the problem.

    Thanks for the help!


    • Edited by KS777 Friday, May 20, 2016 8:03 PM
    Friday, May 20, 2016 8:03 PM

Answers

  • Got it.  

    For others reference, in Visual Studio, Project -> Properties.  Driver Settings -> Driver Model value "Type of driver" needs to be WDM not KMDF.

    Don't forget this setting is specific to the type (release/debug) and architecture (x86/x64) of the build.

    • Marked as answer by KS777 Tuesday, May 24, 2016 11:36 PM
    Tuesday, May 24, 2016 10:17 PM

All replies

  • Is your driver using WdfDeviceMiniPortCreate?   I believe SDV only supports pure storport miniports, not mix storport WDF models.


    Don Burn Windows Driver Consulting Website: http://www.windrvr.com

    Sunday, May 22, 2016 1:29 AM
  • I am not using any Wdf functions.  I found some unnecessary Wdf references in my inf file that I removed, but I still get the same error.
    Monday, May 23, 2016 7:42 PM
  • When I dump symbols from my driver from the debugger, it turns out that I do have wdf functions loaded.  Or at least global variables.  I've got WdfDriverGlobals, WdfBindInfo and a few others.  This looks like a Visual Studio problem - there's some setting that is off such that even though I've selected KMDF Driver, it's still adding the Wdf variables.  I looked through all the libraries I include and the "Inherited values;" contains WdfLdr.lib and WdfDriverEntry.lib.  The code compiles fine without them and I've unchecked the "inherit from parent or project defaults" so they won't get linked any more.  Now I don't have any Wdf symbols dumped by x in windbg, but SVD is still unhappy.
    Tuesday, May 24, 2016 1:22 AM
  • Got it.  

    For others reference, in Visual Studio, Project -> Properties.  Driver Settings -> Driver Model value "Type of driver" needs to be WDM not KMDF.

    Don't forget this setting is specific to the type (release/debug) and architecture (x86/x64) of the build.

    • Marked as answer by KS777 Tuesday, May 24, 2016 11:36 PM
    Tuesday, May 24, 2016 10:17 PM