TFS 2010 Connection Error


  • I am havng a problem configuring my team foundation server from the Administration Console. I have installed:

    Windows 7 Professional

    SQL Server 2012 - Developer

    Visual Studio 2010 Ultimate

    Team Foundation Server 2010

    When I go into the administration console and begin the configuration process, for a basic configuration, I first get a warning in the readiness checks. It reads:

    [ Configuration Database ] The following database already exists, but cannot be used as part of this installation of Team Foundation Server: Tfs_Configuration. The database is hosted on the following server: Matthew-PC\SqlExpress. You can manually delete or rename this database before you continue, but it is not required. If you do not, the database will be renamed as part of the installation process.

    Then, when I try to go ahead and configure anyway, I get this error

    TF255356: The following error occurred when configuring the Team Foundation databases: Error occurred while executing servicing step Register Configuration Database for component Install during Install: TF246017: Team Foundation Server could not connect to the database. Verify that the server that is hosting the database is operational, and that network problems are not blocking communication with the server.. For more information, see the configuration log.

    How can I fix this?

    I am simply trying to collaborate with other students in my class on a project using TFS and Visual Studio.  If more information is needed or my question is not clear, please let me know and I will be happy to elaborate.  Thanks so much for your time!


    Monday, April 23, 2012 5:02 AM

All replies

  • As an addition:  In my list of installed programs, SQL Server 2008 and SQL Server 2008 R2 are also listed as I know at least 2008 is required to use Team Foundation Server 2010.

    Monday, April 23, 2012 5:06 AM
  • Hi Matt,

    Thank you for your post.

    Seems Tfs-Configuration databse has already hosted on server: Matthew-PC\SqlExpress, now you want to configure new TFS on new SQL instance, it is conflict with the exists one.

    Could you remove/rename the database so that you can configure new one.

    Best regards,

    Lily Wu [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, April 24, 2012 2:37 AM
  • Hi Matthew,

    You mentioned that you have SQL Server 2012 Developer Edition, but looks like you are trying to use an instance of SQL Express.

    Can you check if Tfs_Configuration database exists in you SQL Express instance?

    Was this your first attempt to configure TFS?

    If you do have Tfs_Configuration database, can you rename or drop it and try to configure again? Make sure that the database is not used before you drop it.



    Saturday, April 28, 2012 5:13 AM
  • Here is a picture of what my Sql Server Management Studio Window Looks Like:

    I have tried many times to congifure TFS but neither of these databases work.  I have also since tried removing them and renaming them as well. On my computer, I had previously uninstalled SQL Server 2008 R2 and then installed SQL Server 2012 and to be honest do not think I uninstalled R2 correctly. :-P It sounds as though I need to reinstall SQL Server 2008 R2 for TFS to work correctly and to allow me to configure it.  If no other way seems feasable for me to make things work with SQL Server 2012, can someone please point me to a resource that will show me how to uninstall SQL Server 2012 correctly and reinstall 2008 R2?

    Thank you so much for the help from everyone!  I hope to be able to help others on the forum in the future!

    Monday, April 30, 2012 7:36 PM
  • Hi Matt,

    About un-install SQL server 2012 and re-install SQL server 2008 R2, i suggest you go to SQL forum, you can get better support there.

    If anything about TFS is unclear, please free feel to let me know.

    Best regards,

    Lily Wu [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, May 01, 2012 2:46 AM
  • Hi Matthew,

    according to screenshot you have SQL Express 2008 (not SQL Express 2008 R2). If you do not mind, could you zip up logs from C:\ProgramData\Microsoft\Team Foundation\Server Configuration\Logs folder and e-mail them to me?

    My email: vladimir.khvostov @ mstf dot com.



    Wednesday, May 02, 2012 1:42 AM
  • Matt,

    Let me just ask a question to clarify things.

    Are you looking to setup TFS on your machine to have other use your machine as the TFS environment?  or are you trying to setup your environment to connect to an already existing TFS environment?


    Enrique Lima | Senior Consultant - Pinnacle of Indiana| http://geekswithblogs.com/enriquelima

    Saturday, May 05, 2012 9:45 PM
  • I am sorry, how can this be marked as the answer?  I have noticed a number of posts going "answered" like this.  If you read the question an issue correctly, SQL Server 2012 is not even part of the issue.

    Enrique Lima | Senior Consultant - Pinnacle of Indiana| http://geekswithblogs.com/enriquelima

    Sunday, May 20, 2012 11:58 AM
  • Dear Everyone,

         After a few months of using SQL Server Management Studio, I have finally begun to understand how to use things and what is actually happenening.  I had tried all along to continue to get TFS to work, and now I have finally enabled my TFS. 

        I believe what was going on, (and since months have gone by, configurations could have changed and the problem could definitely have been solved in other ways), based on your replies, was that I was typing in the name of the server incorrectly, when I was asked which server to configure.  I needed to use "Matthew-PC" and type this exactly, NOT "Matthew-PC\" or anything else.  This server did not appear, however, in my drop down list.  Therefore, I believe that was why it was so difficult for me to discover what to type.  It also seems that TFS 2010 and SQL Server 2012 work in perfect harmony, which is great. 

    I'm so sorry if my error was one of simplicity and inexperience. 

    Thank you for all your concern and assistance.  I'm not sure how to close out this post, but thanks again!



    Saturday, September 22, 2012 4:48 PM