locked
VSTS Test project not building as SDK path not found RRS feed

  • Question

  • User131356 posted

    I am trying to use VSTS automation for building my project as well as executing it on testcloud. When it is trying to build the test project i am getting the below errors.

    2017-08-22T10:07:25.5923735Z d:\a\1\s\FrontEnd\Mobile\packages\Xamarin.UITest.2.0.9\tools\test-cloud.exe submit "d:\a\1\b\Release\com.cmdin.projectnewbar2.apk" ef6dad0a65e32d82fb15f2fb890ad5f8 --user xyz@gmail.com --devices 556d891d --series "master" --locale "enUS" --assembly-dir "d:\a\1\b\Release\test-assembly" --nunit-xml "d:\a\1\b\Release\test-assembly\xamarintest221.0.xml" 2017-08-22T10:07:25.9295668Z ##[error]Access to the path 'C:\Program Files (x86)\Android\android-sdk\cmake\3.6.4111459' is denied. 2017-08-22T10:07:25.9634443Z ##[error]System.Exception: Unexpected exit code 1 returned from tool test-cloud.exe

    There is no option to specify android sdk path in uitest project options on VSTS.

    Please help me. Thanks in advance.

    Tuesday, August 22, 2017 10:21 AM

All replies

  • User340886 posted

    I'm having same exact error.... Only different version

    d:\a\1\s\packages\Xamarin.UITest.2.0.10\tools\test-cloud.exe submit "d:\a\1\b\Release\xxxxxxxxxxxxxxxxxx.apk" xxxxxxxxxxxxxxxxxxxxxxxxx --user xxxxx@xxxx.com --devices 74766b94 --series "master" --locale "en_US" --assembly-dir "d:\a\1\s\xxxxxxxxxxxxxxxxxx\xxxxxxxxxxxxxxxxxx.UITests\bin\Release" 2017-08-22T11:11:15.7529504Z ##[error]Access to the path 'C:\Program Files (x86)\Android\android-sdk\cmake\3.6.4111459' is denied. 2017-08-22T11:11:15.7859494Z ##[error]System.Exception: Unexpected exit code 1 returned from tool test-cloud.exe 2017-08-22T11:11:15.7859494Z at Microsoft.TeamFoundation.DistributedTask.Task.Internal.InvokeToolCmdlet.ProcessRecord() 2017-08-22T11:11:15.7859494Z at System.Management.Automation.CommandProcessor.ProcessRecord() 2017-08-22T11:11:15.8089499Z ##[error]PowerShell script completed with 1 errors. 2017-08-22T11:11:15.8099509Z ##[section]Finishing: Test $(build.binariesdirectory)/Release/*.apk with Xamarin.UITest in Xamarin Test Cloud

    The weird thing upload locally with same command works perfectly so probably it's something in VSTS ?

    Tuesday, August 22, 2017 11:22 AM
  • User342578 posted

    I too am having the same issue:

    Submit d:\a\1\b\Release\ZZZZZZZ.apk to Xamarin Test Cloud.
    d:\a\1\s\packages\Xamarin.UITest.1.3.8\tools\test-cloud.exe submit "d:\a\1\b\Release\ZZZZZZZ..apk" 56455d242d3cef1b7e316355e6cf7188  --user zzzz@zzzzz.com --devices de9f121e --series "master" --locale "en_US" --assembly-dir "d:\a\1\b\Release\test-assembly" --nunit-xml "d:\a\1\b\Release\test-assembly\xamarintest_15.0.xml"
    Access to the path 'C:\Program Files (x86)\Android\android-sdk\cmake\3.6.4111459' is denied.
    System.Exception: Unexpected exit code 1 returned from tool test-cloud.exe
    
    Thursday, August 24, 2017 7:54 PM
  • User341992 posted

    Im having the same problem. Does anyone have a fix for this

    Friday, August 25, 2017 1:18 AM
  • User324818 posted

    I'm also experiencing this when trying to use both Xamarin Test Cloud & Mobile Center Test through VSTS

    Friday, August 25, 2017 2:12 AM
  • User42834 posted

    Thanks for reporting! We are looking into this now and will have a resolution shortly. I will update this thread when I have an update, apologies for the disruption.

    Friday, August 25, 2017 4:08 PM
  • User345179 posted

    Any update on this I am getting the same error?

    2017-08-28T20:12:50.1325186Z Access to the path 'C:\Program Files (x86)\Android\android-sdk\cmake\3.6.4111459' is denied. 2017-08-28T20:12:50.1325186Z 2017-08-28T20:12:50.1375398Z Preparing tests... failed. 2017-08-28T20:12:50.1385189Z Command failed: Cannot prepare UI Test artifacts. Returning exit code 1.

    Tuesday, August 29, 2017 6:54 AM
  • User338940 posted

    @"GlennWester.4818" any updated ETA on this?

    Tuesday, August 29, 2017 7:16 AM
  • User74728 posted

    We are experiencing this as well. Any update would be appreciated!

    Tuesday, August 29, 2017 7:11 PM
  • User42834 posted

    Hi @MichaelWanke and @SangamTeam this fix should be available by mid week, I will check with the team again and update here shortly. Thank you for your patience.

    Tuesday, August 29, 2017 7:49 PM
  • User74728 posted

    @"GlennWester.4818" Thank you for the update!

    Tuesday, August 29, 2017 7:54 PM
  • User42834 posted

    @MichaelWanke We're expecting this by tomorrow afternoon.

    Tuesday, August 29, 2017 8:02 PM
  • User42834 posted

    I've heard from the team that the fix is now live. Please rerun your builds and ensure the upload is successful, please let me know otherwise!

    Thursday, August 31, 2017 2:53 PM