locked
Warning from TMI creation: The configured application base directory ... RRS feed

  • Question

  • After running a test successfully within Microsoft Test Manager (MTM), we attempted to remove a directory ('\\MyServe\MyPath) and see how MTM handled the missing folder. The outcome was not what was expected.  The status of the job showed a green "Passed". This is very bad, as our testers will not know that there was a problem. 

    I took a look at the log, and it is catching the bad path correctly.  But, then it decides to use "the test directory".  We do not want this.  Is there a way to have the job error when this type of situation occurs? There is an advanced test settings for Hosts called "For tests that cannot be run on the specified host:" and we have checked off "Don't run".  This setting, however did not make a difference.

    log:
    Warning from TMI creation: The configured application base directory '\\MyServe\MyPath' does not exist.  The test directory will be used instead..

    Thank you.
    • Moved by Vicky SongMicrosoft employee Thursday, January 5, 2012 5:07 AM MTM issue (From:Visual Studio Team System - Testing)
    • Moved by Gautam Goenka [MSFT] Monday, January 9, 2012 1:06 PM (From:Testing with Visual Studio Test Manager (MTM))
    Tuesday, January 3, 2012 5:18 PM

All replies

  • Hi jp-DevTeam,

    I am moving your case to the MTM forum so that you can get better support there.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us
    Thursday, January 5, 2012 5:06 AM
  • Anyone? This continues to be a problem for us.
    Wednesday, January 11, 2012 2:31 PM
  • Can you tell what’s the relationship between the removed directory and your tests? It will help people understand your situation.  Thanks.
    Thursday, January 12, 2012 2:42 AM