none
Microsoft Azure AD Sync service not start after reboot

    Question

  • Good morning all.

    I've a strange situation, i've searched on the internet but i've found nothing relevant.

    From three days, I am receiving e-mails from MSOnline services, saying "Unhealthy Identity synchronization Notification: Azure Active Directory did not register a synchronization attempt from the Identity synchronization tool in the last 24 hours for <MYCUSTOMER>."

    I've tried to restart the Microsoft Azure AD Sync service, that i've found stopped, but if i try to start it takes a long time and after says "Could not start the Microsoft Azure AD Sync service. Specific error code -2147467259".

    I've tried to uninstall and reinstall the AADConnect: when i install it, the procedure goes well and the directory syncronization happens, but after i reboot the server the service won't start again with the same specific error code.

    I've googled a lot but ca't find anithing relevant...

    Any help would be appreciated a lot.

    Many thanks and regards.

    Luca

    Thursday, March 9, 2017 2:21 PM

All replies

  • Check your event logs (System) for entries specific to the service, they should give you more info.
    Thursday, March 9, 2017 9:33 PM
  • Good morning all.

    I've a strange situation, i've searched on the internet but i've found nothing relevant.

    From three days, I am receiving e-mails from MSOnline services, saying "Unhealthy Identity synchronization Notification: Azure Active Directory did not register a synchronization attempt from the Identity synchronization tool in the last 24 hours for <MYCUSTOMER>."

    I've tried to restart the Microsoft Azure AD Sync service, that i've found stopped, but if i try to start it takes a long time and after says "Could not start the Microsoft Azure AD Sync service. Specific error code -2147467259".

    I've tried to uninstall and reinstall the AADConnect: when i install it, the procedure goes well and the directory syncronization happens, but after i reboot the server the service won't start again with the same specific error code.

    I've googled a lot but ca't find anithing relevant...

    Any help would be appreciated a lot.

    Many thanks and regards.

    Luca


    I've just started having the same problem. Did you find a fix?
    Tuesday, March 20, 2018 1:08 PM
  • No way.

    I noticed that I have this problem only on the SBS systems...that ones that I have migrated to EOL.

    The dirsync is installed on the old SBS machine, which is now been used ad DC and file server.


    Another strange thing is that when one of these SBS of my Customer brokes up the ADSYNC...also the other ones brokes.

    The only way i have to make it work again is to uninstall and reinstall...no other ways, no error details.

    I think it's an SBS related issues...other customers without SBS (or with the dirsync installed on aonther server/DC instead of the SBS) works without problems/ interruptions.


    HTH...Cheers

    Luca

    Tuesday, March 20, 2018 1:56 PM