none
Performance Tookit interfering with reporting on Process memory? RRS feed

  • Question

  • I was introduced to the Windows Performance Toolkit the other day, and I wanted to give it a try. So I installed the it as well as the Application Verifier.

    I wanted to profile my application's heap usage, using XPerf.

    I used the following batch command to start it up:

    reg add "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\<my app name here>.exe" /v TracingFlags /t REG_DWORD /d 1 /f
    xperf -on Base+Cswitch -BufferSize 2048 -MinBuffers 200 -MaxBuffers 200
    xperf -start HeapSession -heap -Pids 0 -BufferSize 2048 -MinBuffers 200 -MaxBuffers 200 -stackwalk HeapAlloc+HeapRealloc+HeapFree

    I used the following batch command to shut it down.

    set savefile=%CD%\my_saved_file_heap.etl
    xperf -stop HeapSession -stop -d %savefile%
    reg delete "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\<my app name here>.exe" /v TracingFlags /f

    So this worked nicely, but now I don't think it is turned off, or rather it's now always profiling my app. Even when I turn this off, my application is now slowed to a crawl, and the smoke tests which used to take 7 minutes, now takes an hour: which seems a dead give-away this tool was doing something...

    So to try to resolve it, I rolled back my system to before I installed the Windows Performance Toolkit. But I still have this performance problem. I'm not sure what to look for in diagnosing this problem. Should I use process monitor to watch for suspicious activity while my app is running?

    I noticed while running the xperf profiler, that my application would register very little memory in process explorer. But now, all processes are affected. See the linked image.

     

    Friday, December 17, 2010 6:21 PM

Answers

  • The only resolution I've had is that I eliminated the performance drop for my application. Apparently some flags (in the registry) were left turned on for my particular application:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\<my app name here>

    However, process explorer is still reporting ridiculously low numbers for memory consumption, as my linked image shows. 

    [Edit]

    Solved. Process explorer reports incorrect numbers when regional settings is set to use a comma instead of a period.

    • Edited by Chris P Johnson Wednesday, December 22, 2010 8:58 PM solved problem
    • Marked as answer by Chris P Johnson Wednesday, December 22, 2010 8:58 PM
    Sunday, December 19, 2010 1:58 PM