none
SQL Server 2008 SSCM - Missing Startup Parameter Property?? RRS feed

  • Question

  • Has anybody every seen missing 'Startup Parameters' property of SQL Service in SSCM (Windows Server 2008 R2)?

    It should look like this:

    Why would 'Startup Parameters' property be missing and how do I resolve ?

    Thanks in advance,


    Phil Streiff, MCDBA, MCITP, MCSA

    • Edited by philfactor Monday, February 11, 2019 2:14 PM
    Monday, February 11, 2019 1:45 PM

Answers

  • That's strange. Anyway, one workaround I can think of is to manually add the startup parameters to the registry. Steps below.

    1. To know the path to the registry, run the following. This query returns all startup parameters along with their registry paths that currently exist. 

    Select * from sys.dm_Server_registry where value_name like 'SQLArg%'

    2. Once you get the paths (they will be the default ones unless you changed them in the past which is unlikely), run regedit in "run" and navigate to that path. 

    3. Right-click and add new startup parameters that you wish mimicking the ones already out there. 

    4. Run the query in #1 and ensure the new startup parameter correctly shows up. 

    If the above doesn't work, there's another way to have them added using PowerShell. 


    Please remember to click "Mark as Answer" if my response answered your question or click "Vote as helpful" if it helped you in any way.

    • Marked as answer by philfactor Monday, February 11, 2019 4:51 PM
    Monday, February 11, 2019 2:34 PM
  • Thanks, Mohsin.

    It turns out, I had reduced security privilege on the server. When I was granted local administrator on the box, then the 'Startup Parameters' property appeared under Advanced tab of SQL Service in SSCM.

    Learned something new today :)

    Thanks,


    Phil Streiff, MCDBA, MCITP, MCSA

    • Edited by philfactor Monday, February 11, 2019 4:51 PM
    • Marked as answer by philfactor Tuesday, February 12, 2019 2:09 AM
    Monday, February 11, 2019 4:51 PM

All replies

  • That's strange. Anyway, one workaround I can think of is to manually add the startup parameters to the registry. Steps below.

    1. To know the path to the registry, run the following. This query returns all startup parameters along with their registry paths that currently exist. 

    Select * from sys.dm_Server_registry where value_name like 'SQLArg%'

    2. Once you get the paths (they will be the default ones unless you changed them in the past which is unlikely), run regedit in "run" and navigate to that path. 

    3. Right-click and add new startup parameters that you wish mimicking the ones already out there. 

    4. Run the query in #1 and ensure the new startup parameter correctly shows up. 

    If the above doesn't work, there's another way to have them added using PowerShell. 


    Please remember to click "Mark as Answer" if my response answered your question or click "Vote as helpful" if it helped you in any way.

    • Marked as answer by philfactor Monday, February 11, 2019 4:51 PM
    Monday, February 11, 2019 2:34 PM
  • Thanks, Mohsin.

    It turns out, I had reduced security privilege on the server. When I was granted local administrator on the box, then the 'Startup Parameters' property appeared under Advanced tab of SQL Service in SSCM.

    Learned something new today :)

    Thanks,


    Phil Streiff, MCDBA, MCITP, MCSA

    • Edited by philfactor Monday, February 11, 2019 4:51 PM
    • Marked as answer by philfactor Tuesday, February 12, 2019 2:09 AM
    Monday, February 11, 2019 4:51 PM
  • Ah, I see. Yes, the documentation also states the following. 

    Configuring server startup options is restricted to users who can change the related entries in the registry. This includes the following users.

    1. Members of the local administrators group.

    2. The domain account that is used by SQL Server, if the Database Engine is configured to run under a domain account.

    Thanks for letting us know :)


    Please remember to click "Mark as Answer" if my response answered your question or click "Vote as helpful" if it helped you in any way.

    Monday, February 11, 2019 5:16 PM