none
WCF-WebHttp adapter gives always the same error when connect with the TFService odata Api. 405 Method not allowed RRS feed

  • Question

  • In biztalk 2013 I use the wcf-webhhtp adapter  to work with the Team Foundation Service Odata Api. By every request(even GET requests) gives the following error:

    Error details: System.Net.WebException: The remote server returned an unexpected response: (405) Method Not Allowed.

    <?xml version="1.0" encoding="utf-8" standalone="yes"?>

    <error xmlns=" ">

      <code></code>

      <message xml:lang="en-US">The URL representing the root of the service only supports GET requests.</message>

    </error> 

    The settings are:

    • endpoint: https://tfsodata.visualstudio.com/DefaultCollection/
    • urlmapping: <BtsHttpUrlMapping><Operation Name="AddWorkItem" Method="GET" Url="/WorkItems(1)" /></BtsHttpUrlMapping>
    • security mode: Transport 
    • credential type: Basic
    • HTTP Headers: Content-Type: text/jsonContent-Length: 0
    • Suppres body for verbs: GET

    It works fine when i make the same call in Fiddler. Doe anyones knows the solution for this problem?

    Regards,

    Wednesday, October 23, 2013 8:39 AM

Answers

  • Hi Lennart

    Do you mean that you have installed Fiddler to monitor the process, and it works fine when make the call in Fiddler, but it still give same error message, I think it is really weird. If you use IIS, I’d also like to suggest you to enable the failed Request Tracing in IIS, this will give some hints on why a request has failed. 

    hope it helps,

    Regards


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Pengzhen Song Tuesday, October 29, 2013 10:43 AM
    Saturday, October 26, 2013 3:35 AM