locked
Error occurred in deployment step 'install app for sharepoint' the system account cannot perform this action. RRS feed

Answers

  • Finally, I could solve this, following the below steps.

    1. First of all, create a new AD user, say, sp_appuser.

    2. Make this user a Local Admin.

    3. Also, make this user a Farm Admin.

    4. After this, create a Login in SQL server for this user. Just give Public role for this user.

    5. In the User Mapping section for this user, make this user DBO for App Management DB, Subscription Settings DB and the current content DB where you are deploying the app.

    6. Then login into the server using this new user.

    7. Open Visual Studio as Administrator and open your app solution and deploy it. It worked successfully.

    Thanks a lot to the following SharePoint Stack Exchange link.

    http://sharepoint.stackexchange.com/questions/80812/error-occurred-in-deployment-step-uninstall-app-for-sharepoint-the-system-acc

    Note: Look at the first answer (this is not marked as answer, though) by ateet.


    Ven

    • Marked as answer by Venh Tuesday, September 8, 2015 6:04 AM
    Tuesday, September 8, 2015 6:03 AM

All replies

  • Finally, I could solve this, following the below steps.

    1. First of all, create a new AD user, say, sp_appuser.

    2. Make this user a Local Admin.

    3. Also, make this user a Farm Admin.

    4. After this, create a Login in SQL server for this user. Just give Public role for this user.

    5. In the User Mapping section for this user, make this user DBO for App Management DB, Subscription Settings DB and the current content DB where you are deploying the app.

    6. Then login into the server using this new user.

    7. Open Visual Studio as Administrator and open your app solution and deploy it. It worked successfully.

    Thanks a lot to the following SharePoint Stack Exchange link.

    http://sharepoint.stackexchange.com/questions/80812/error-occurred-in-deployment-step-uninstall-app-for-sharepoint-the-system-acc

    Note: Look at the first answer (this is not marked as answer, though) by ateet.


    Ven

    • Marked as answer by Venh Tuesday, September 8, 2015 6:04 AM
    Tuesday, September 8, 2015 6:03 AM
  • Hi Ven,

    Thanks for your sharing, it would be helpful to those who stuck with the similar issue.

    Thanks


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, September 8, 2015 6:58 AM