none
Outlook replace all form region RRS feed

  • Question

  • Hi All,

    I have a replace-all form region and a problem with keyboard shortcuts has cropped up. While Cut & Paste work for the form region, other shortcuts such as sending an email (alt+s) do not work. How can I make sure all of the shortcuts are working?

    In addition, is it possible to have a shortcut for a OlkCommandButton?

    Thanks,

    Tom

    Monday, September 17, 2018 9:46 PM

Answers

All replies

  • According to my research, I think you could try to use Ribbon-Accelerator to implement it. And gets and sets the keyboard shortcuts for Separate, Replacement, and Replace-All form regions.

    For the OlkCommandButton, I'm afraid this can't be realized. 


    As I understand it, It's just set the button to Add and Delete. 

    More information, please see:

    Outlook Navigation pane regions

    Outlook is a featured application for Add-in Express

    OlkCommandButton Object (Outlook)

    Hopefully it helps you.

    Best Regards,

    Simon


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread.


    Tuesday, September 18, 2018 1:52 PM
    Moderator
  • Hi Thomas,

    This thread has been around for a long time. Did you solve the problem? Please remember to mark the reply as answer if it helped. Please help us close the thread. Thanks for your understanding.

    If your issue is still exist then let us know about that, we will try to suggest you further to solve the issue.

    Regards,

    Simon


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread.

    • Marked as answer by Thomas Lee3 Tuesday, September 25, 2018 1:07 PM
    • Unmarked as answer by Thomas Lee3 Tuesday, September 25, 2018 1:07 PM
    Tuesday, September 25, 2018 10:39 AM
    Moderator
  • Hi Simon,

    I did find a solution for my issue and that was to use the Accelerator property within the OlkCommandButton interface.

    CComPtr < Outlook::_OlkCommandButton> m_spSendButton;

    ...

    m_spSendButton->put_Accelerator(CComBSTR("s"));

    Using that property solved my issue.

    Thanks,

    Tom

    Tuesday, September 25, 2018 1:07 PM
  • It is glad to hear that you have found the solution and thanks for sharing it with us. If you have any question, or update, please feel free to let me know.

    Regards,

    Simon


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread.

    Tuesday, September 25, 2018 1:12 PM
    Moderator