installation bug found SQL Server 2005 RRS feed

  • Question

  • Hi!

    I had the earlier builds and this did not happen but:

    just downloaded SQL Server 2005 (RTM) from msdn

    When selecting to install integration services (amoungst other options), whilst installating it gives me an error saying I do not have admin privledges to install one of the .NET libraries/runtime files? I cannot remember the file name at all im afraid.

    Error: 0x80131501

    So I cancelled the install and just installed everything but the integration services... and it works fine now. I do not know if this is a bug but just thought I would let you know
    Friday, October 28, 2005 11:55 AM


All replies

  • Hello.

    My fix is the same as yours. Install a little less at the time. Do it in two steps.


    The error message is (obviously) wrong. I have seen this when the system has memory starvation.

    Do you have enough ram?

    Are you running inside Virtual PC/Server on a newly installed image that has not yet grown its swap space?
    Friday, October 28, 2005 1:13 PM
  • Hi!

    You would be insane to install it on a VPC system lol

    I have more than enough RAM - 512MB, I have also put in an extra 512MB but makes no difference.

    Any other solutions? This issue should be sorted out before the official ship date.

    Friday, October 28, 2005 5:00 PM
  • Greetings

    > You would be insane to install it on a VPC system lol

    You must know something I don't.

    > Any other solutions? This issue should be sorted out before the official ship date.

    I tried to raise the subject in other channels with SEPT CTP, but interest is slim.
    My guess is that it is a Windows Installer bug, and ideally should be solved by another team.

    I guess it would help if you gave a few more details about your environment.

    btw, some times litening is better than laughing,

    Friday, October 28, 2005 6:56 PM
  • sometimes listening to an Employee who has been at Microsoft for a year+, and who is part of another team for 4 years, helps too and who is about to return back after he gets his university degree.

    Environment is what I posted in my initial post. take another read.

    what else do you want to know about environment?

    i wouldnt say it is an installer bug. It may make sense but i dont believe it is.

    interest should be huge and i am sure it will be as when shipping a product which does not install is a bug fallback for the product
    Friday, October 28, 2005 9:45 PM
  • Hello again
    Excuse me if I offended you, I was trying to help.

    Using virtual server has been Microsofts own choice for working with the betas. I have seen it used by three of the leading "Yukon" experts in the world (one of them hatet virtual server). I myself have run "Yukon" versions in both VPC and VS for a years time. Lol as much as you want.

    Installation issue
    Well, we didn't get enough momentum on it. The bits are in production now.
    Your error code is COR_E_SYSTEM. It generally is declared in the exception base class and means "Exception for this error not implemented". Without an error message it is hard to read anything from it.

    I must have been unclear. I ment enough information about you hardware and software to reproduce your bug. Obviously, everybody else is not having your problem, so more information about your environment is needed.

    Saturday, October 29, 2005 7:08 AM
  • Sure


    P4 3GHz 800FSB
    512MB DDR400 RAM
    200GB 7200 RPM 8MB cache
    160GB 7200RPM 2MB Cache
    Intel 865GBF motherboard

    network card, graphics card (256MB AGP 8x), sound card

    Software running:

    WS2003 Enterprise edition (with SP1)
    VS.NET 2003 .NET framework 1.1
    SQL Server 2000 Enterprise edition (MSDN)

    Office 2003 (with sp2)

    anything else?
    Saturday, October 29, 2005 11:47 AM
  • OK. Good for you. No caveats that I can see.
    What is the virus/virus killer situation?

    There is no doupt that there are people with the same hardware configuration that has successfully installed all parts of SQL Server 2005, or you wouldn't be the only one screaming.

    I haven't tried it with Office SP2, which leads me towards thinking there is a (remote) chance that it could be version panic with SQLXML, Windows Installer or something. (I know there is something called side by side execution, it's just that I am not convinsed)

    Have you tried re-running setup and install (just) Integration Services on top of the rest?

    If it does not work, you could try deinstalling any data access components optionally installed with office or office SP2 but it's a long shot.

    If you had added 512MB RAM, you could comfortably run SQL in VPC or Virtual Server.

    BTW: did you (in your first install) do a cutom install and include the samples?
    Saturday, October 29, 2005 1:00 PM
  • Virus killer situation is none on that computer as it is not connectable to the internet. But I did scan the system anyway using Norton Anti Virus (latest definations etc...) from another computer and there are no viruses - so we can take this out the equation.


    I did re-run setup and I was able to select the integration services alone (after deselecting it the first time I installed SQL Server 2005) and it did install fine.

    I have also tried to run setup and choosing all the options, including integration services and the same problem happened again.

    I will try to de-install data access components and see what happens.

    I also have another issue which is in the SQL Server tools forum, relating to profiler and I think that the error of that is related to data access components... hopefully If i remove the data access components and perhaps re-install it I can solve that problem and who knows, this problem too with the installation of SQL Server 2005


    I will update you with the steps to be done on my end...



    Saturday, October 29, 2005 7:31 PM
  • P.S - just checked, SQL Server 2005 Enterprise edition is up for grabs, it was said it would be next week but its up now! So, I will see if i encounter a problem with that setup process


    Saturday, October 29, 2005 7:33 PM
  • OK, well I am installing SQL Server 2005 ENT edition and it still produces the error when installing integration services (selected all options except reporting services)



    Failed to install and configure assemblies: C:\program files\Microsoft SQL Server\90\DTS\tasks\Microsoft.SqlServer.MSMQTask.dll in the COM+ catalog.

    Error: -2146233087.

    Error Message: Unknown Error 0x80131501

    Error description: You must have administrator credentials to perform this task. Contact your system administrator for assistance.


    Now, I am installing, and logged in all the time, as administrator! So I have admin privledges no doubt.

    Even after following the help link file for this error message, there is still the problem. It tells me to make sure that the DTC is started on the Network Service Account, which it is, and to restart the service and try again... did this but I still get the error.


    Saturday, October 29, 2005 11:33 PM
  • I also have this installation problem installing Enterprise edition (with admin priveleges.)

    Again, no problem with DTC running.

    I do have SQL 2000 installed.
    Tuesday, November 8, 2005 10:20 AM
  • Hi all-
    I'm new here, but found this when searching for the error I recieved.
    I just attended the Launch event here in Chicago yesterday, and decided to install on my home system.  I recieved the similar errors as discussed here (trying to install all features.

    Product: Microsoft SQL Server 2005 -- Error 29521. SQL Server Setup failed to execute a command for server configuration. The error was [Microsoft][SQL Native Client][SQL Server]The default full-text language is not supported by the full-text search component.. Refer to the server error logs and Setup logs for detailed error information.

    I'll try without integration services too

    Hardware shouldn't be an issue:
    Dual XEON 2.2
    2GB Ram
    XP SP2
    8 GBdisk free

    Friday, November 11, 2005 10:40 PM
  • Hi
    I am using Microsoft 2005 RTM version and recieved the same error.

    Failed to install and configure assemblies C:\Program Files\Microsoft SQL

    Server\90\DTS\Tasks\Microsoft.SqlServer.MSMQTask.dll in the COM+ catalog.

    Error: -2146233087
    Error message: Unknown error 0x80131501
    Error description: The transaction has aborted

    CTP September version was working properly on my machine, can any one help



    Monday, November 14, 2005 1:45 PM
  • Issue resolved.

    see my new thread about installation issue resolved


    Monday, November 14, 2005 9:40 PM
  • I have the same problems, during sql2005 installation on win2003

    Failed to install and configure assemblies C:\mssql2k5\90
    \DTS\Tasks\Microsoft.SqlServer.MSMQTask.dll  in  the  COM+  catalog.  Error:  -2146233087
    Error  message:  Unknown  error  0x80131501
    Error description: You must have administrative credentials to perform this task. Contact your system
    administrator for assistance.


    @ahmedilyas: installing new OS is not the solution.

    Wednesday, January 25, 2006 7:29 AM
  • basta - I have clearly stated that before that re-installing the OS is not the solution - I know this myself but that seems to be the only way unfortunatly as there is a problem with the way SP1 is installed on WS2003 systems



    Wednesday, January 25, 2006 6:59 PM
  • I had the same problem with Windows XP SP2 trying to install SQL-Server 2005 Developer (dtc running).

    After uninstalling the DTC (as described in Article 891801) I was able to install the SQL Server 2005 integration services without any errors (warning at start of setup though).

    Unfortunately I was unable to re-install the DTC afterwerwards, it installed fine but would not start. Took quite a bit of time before I figured out some of the registry keys were not accesible to the 'Network Service' account. I ended up fixing that problem by adding the 'Local Service' account to the (local) Administrators group, although I would be happy if someone could give me a better solution to this problem (MSDTC failing to start because 'Local Service' account not being able to acces HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CID).

    After getting the DTC service back to work I was able to install SQL Server 2005 Developer without any warnings or errors.

    One last remark: The machine I tried this on previously had both a MSDE and (a) SQL Server 2005 express CTP edition installed, maybe this was part of the problem.

    Friday, February 17, 2006 2:21 PM
  • I just got a copy of Sql Server 2005 Developer and I have the same error.

    This should not be a memory problem because I have 1 Gig ram.

    I will try to disable Integration Services next and see what happens
    Thursday, March 23, 2006 6:57 AM

    This wasn't exaclty my problem, but it lead me in the right direction. I downloaded RegMon from sysinternals.com and set it monitor "setup.exe;msiexec.exe" and to just log errors. Sure enough there were about 5 or 6 nodes(?) all in the "Microsoft.SqlServer.Dts.Tasks.MessageQueueTask" cluster in the registry that I needed allow my account to be able access. 

    Thanks for the post!

    Thursday, April 6, 2006 10:19 PM
  • I had a very similiar (if not exact) problem:

    Here is how I resolved it.

    Step 1: When the error happened I click on the ? help link in the bottom left corner of the error message and it told me my "DTC could not be confirmed as running".

    Step 2:  I went into "manage computer" and set DTC, and both COM+ services to "autostart".  I also installed Message Queue Services in IIS and set it to "autostart also".

    Step 3:  I uninstalled "Integration Services" that is part of SQL Server 2005.

    Step 4:  I re-installed "Integration Services" and this time I had no errors.

    Tuesday, April 18, 2006 11:09 PM
  • Buddy,

    The solution is to enable the TCP/IP and named pipes! use cliconfg on the cmd prompt to do this!

    I resolved the issue I was having this way!!

    Good Luck!



    Friday, May 5, 2006 7:07 PM
  • Changing the permissions of the registry keys as Mistakite indicated worked fine for me as well, I cleared them as it showed errors, then hit retry, and cleared the next set.

    "This wasn't exaclty my problem, but it lead me in the right direction. I downloaded RegMon from sysinternals.com and set it monitor "setup.exe;msiexec.exe" and to just log errors. Sure enough there were about 5 or 6 nodes(?) all in the "Microsoft.SqlServer.Dts.Tasks.MessageQueueTask" cluster in the registry that I needed allow my account to be able access. "
    • Proposed as answer by SteJo1977 Thursday, December 3, 2009 12:06 PM
    Saturday, January 13, 2007 3:43 AM
  • After reading you mentioning the DTC, we deleted the DTC resource in the cluster and recreated it. Hitting Retry in the SQL SSIS installation resulted in success. If you're problem relates to a stand-alone server why not try (without us having tested due to not being applicable) running the following commands:
    Thursday, December 3, 2009 12:11 PM