none
Continous Integration Using BTDF and TFS RRS feed

  • Question

  • Hi,

    I am trying to Implement Continous Integration using TFS and BTDf

    I was able to Deploy using MSBuild Task by the below Argument by passing the below Argument

    /t:Deploy /p:IsInVSTSBuild=True

    I was able to Deploy but I have one Configuration BTSACCOUNT in BTDF by default it is taking Builtin\users and Deploying it. it tried to move the setting into Setting Generator file but it still take the same when I am Deploying in my build server.

    Can you Please help me with this?

    Thanks,

    Sujith.

    Friday, September 2, 2016 2:50 PM

Answers

  • Hi Sujith,

    The BTSACCOUNT environment variable must be set up in InstallWizard.xml for automatic configuration of permissions for FILE adapter physical paths." Condition="'$(Configuration)' == 'Server' and '$(BTSACCOUNT)' == ''

    <Target Name="DeployFileAdapterPhysicalPaths" Condition="'$(ManageFileAdapterPhysicalPaths)' == 'true' and '$(IncludeMessagingBindings)' == 'true'">
       <SetUpFileAdapterPaths BindingFilePath="$(PortBindings)" UserNameForFullControl="BUILTIN\Users" Mode="SetUp" Condition="'$(Configuration)' != 'Server'" />
    
       <Message Text="The BTSACCOUNT environment variable must be set up in InstallWizard.xml for automatic configuration of permissions for FILE adapter physical paths." Condition="'$(Configuration)' == 'Server' and '$(BTSACCOUNT)' == ''" />
       <SetUpFileAdapterPaths BindingFilePath="$(PortBindings)" UserNameForFullControl="$(BTSACCOUNT)" Mode="SetUp" Condition="'$(Configuration)' == 'Server'" />
     </Target>
    Refer: https://biztalkdeployment.codeplex.com/SourceControl/latest#Dev/V6_0/Framework/BizTalkDeploymentFramework.targets


    Rachit Sikroria (Microsoft Azure MVP)

    • Proposed as answer by Sid Karnati Friday, September 2, 2016 3:40 PM
    • Marked as answer by sujith reddy komma Thursday, September 8, 2016 11:18 AM
    Friday, September 2, 2016 3:25 PM
    Moderator

All replies

  • Hi Sujith,

    The BTSACCOUNT environment variable must be set up in InstallWizard.xml for automatic configuration of permissions for FILE adapter physical paths." Condition="'$(Configuration)' == 'Server' and '$(BTSACCOUNT)' == ''

    <Target Name="DeployFileAdapterPhysicalPaths" Condition="'$(ManageFileAdapterPhysicalPaths)' == 'true' and '$(IncludeMessagingBindings)' == 'true'">
       <SetUpFileAdapterPaths BindingFilePath="$(PortBindings)" UserNameForFullControl="BUILTIN\Users" Mode="SetUp" Condition="'$(Configuration)' != 'Server'" />
    
       <Message Text="The BTSACCOUNT environment variable must be set up in InstallWizard.xml for automatic configuration of permissions for FILE adapter physical paths." Condition="'$(Configuration)' == 'Server' and '$(BTSACCOUNT)' == ''" />
       <SetUpFileAdapterPaths BindingFilePath="$(PortBindings)" UserNameForFullControl="$(BTSACCOUNT)" Mode="SetUp" Condition="'$(Configuration)' == 'Server'" />
     </Target>
    Refer: https://biztalkdeployment.codeplex.com/SourceControl/latest#Dev/V6_0/Framework/BizTalkDeploymentFramework.targets


    Rachit Sikroria (Microsoft Azure MVP)

    • Proposed as answer by Sid Karnati Friday, September 2, 2016 3:40 PM
    • Marked as answer by sujith reddy komma Thursday, September 8, 2016 11:18 AM
    Friday, September 2, 2016 3:25 PM
    Moderator
  • Is this for the File Adapter User Account?  Are you even using that?  Really, no one does.

    Just disable that option by removing this section from the InstallWizard.xml file:

       <SetEnvUIConfigItem>
          <PromptText>Enter the domain-qualified account name used by the BizTalk host instance to read/write from/to FILE port physical paths:</PromptText>
          <PromptValue />
          <ValueType>Text</ValueType>
          <EnvironmentVarName>BTSACCOUNT</EnvironmentVarName>
       </SetEnvUIConfigItem>

    Friday, September 2, 2016 3:45 PM
    Moderator