locked
Sharing wwwroot folder cause 401.3 error in IIS RRS feed

  • Question

  • User1292358045 posted

    I just freshly installed a windows 2008 r2 w/sp1 server with IIS setup.

    I create a folder c:\inetpub\wwwroot\mysite, under that folder, create an empty html file index.htm

    in IIS manager, I create a website, with that folder, in browser, type localhost, everything works fine.

    Then, in order to publish my website to mysite folder, I shared the folder by right click mysite in explorer, click properties, click sharing tab, click share... button to add a share on this folder. I made no changes on security, just share the folder, and nothing else.

    Then I type localhost in browser, it shows:


    Error Summary
    HTTP Error 401.3 - Unauthorized
    You do not have permission to view this directory or page because of the access control list (ACL) configuration or encryption settings for this resource on the Web server.

    Module    IIS Web Core
    Notification    AuthenticateRequest
    Handler    StaticFile
    Error Code    0x80070005
    Requested URL    http://localhost:80/
    Physical Path    C:\inetpub\wwwroot\mysite
    Logon Method    Anonymous
    Logon User    Anonymous

    Even I remove the sharing, the 401 error persists. Only after I delete mysite folder, recreate it again, I can access the website normally until I create the share.

    Is there some setting I omits? Please help.

    Friday, December 6, 2013 8:27 PM

Answers

  • User1292358045 posted

    Actually, I found the reason.

    In IIS manager/Authenication -> Anonymous Authenication, the default website user is ISUR, I changed it to use application pool identity, problem solved.

    Although why default user works fine before folder sharing is beyond me

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 9, 2013 10:08 PM

All replies

  • User1027872733 posted

    Cheng Bao

    HTTP Error 401.3 - Unauthorized
    You do not have permission to view this directory or page because of the access control list (ACL) configuration or encryption settings for this resource on the Web server.

    workaround

    this works in classical asp

    give it a try

    it works in window 7

    goto control panel

    internet information service->

    world wide web services->Application Development Features->check almost all the checkbox in 

    if it does not work 

    Cooldo one more thing check almost all the checkbox in 

    Application Development Features, Common http Features and Security

    Friday, December 6, 2013 9:45 PM
  • User-1853252149 posted

    Open the folder in Windows Explorer.  Add the IIS application pool account to the folder with full control.  Use this account name:

    IIS AppPool\{AppPoolName}

    Replace {AppPoolName} with the name of the app pool this site is running under.

    Jeff

    Monday, December 9, 2013 2:02 PM
  • User1292358045 posted

    Actually, I found the reason.

    In IIS manager/Authenication -> Anonymous Authenication, the default website user is ISUR, I changed it to use application pool identity, problem solved.

    Although why default user works fine before folder sharing is beyond me

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 9, 2013 10:08 PM