none
Error while opening another link in Visual Studio Community 2015

    Question

  • I get the following error if I try to open even Help in my Visual Studio Community 2015 or any updates on the welcome page.

    "The application has failed to failed to start because of incorrect configurations. Please see the application event log or use the command-line tool sxstrace.exe for more details."

    Please tell me how to resolve this issue asap.

    P.S.: Already tried installing Microsoft Visual C++ 2010 SP1 Redistributable Package for (x64) and 

           Microsoft Visual C++ 2010 Redistributable Package for (x64)

    Regards,

    Brijesh.


    Sunday, June 05, 2016 7:58 PM

Answers

  • Hi Brijesh Jain,

    You could tell us which link you tried to open, we can do a test on our side to see what documentation need to download.

    Or you may install all the documentation if your local space is available.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Thursday, June 16, 2016 6:55 AM
    Moderator

All replies

  • Hi Brijesh Jain ,

    Thank you for posting in MSDN forum.

    In order to have a better understanding of this  issue, there is a clarifications with you:

    >>if I try to open even Help in my Visual Studio Community 2015 or any updates on the welcome page.
    Do you mean when you pressed F1 to show the help viewer and click a website page link then the error message shows in the VS “Start Page”?

    >>"The application has failed to failed to start because of incorrect configurations. Please see the application event log or use the command-line tool sxstrace.exe for more details."

    I did a research about this issue, most are about the missing the correct C++ runtime components for your type of system.

    Since your VS edition is VS 2015 Community, you may have try to download Visual C++ Redistributable Packages for Visual Studio 2015 from the following link:
    http://www.microsoft.com/en-sg/download/details.aspx?id=48145


    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Tuesday, June 07, 2016 7:17 AM
    Moderator
  • Hello,

    Thanks for attending the matter. 

    For your first question : Yes. I meant while pressing F1 to show the help viewer or clicking a website page link on the VS "Start page".

    And I had already Visual C++ Redistributable for Visual Studio 2015 installed on my pc.  But, as you asked, i again reinstalled it but still the error exists.

    Regards.

    Tuesday, June 07, 2016 1:48 PM
  • Hi Brijesh Jain,

    If you have already installed Visual C++ Redistributable packages, you may go to Help> set Help Content in "Launch in Browser":

    Then, you could also check in Options> Environment if you have enabled the Startup choice:


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Thursday, June 09, 2016 7:51 AM
    Moderator
  • Still I'm getting the same error. But, when I changed the "Set Help Preference" back to "Launch in Help Viewer", I got this message.

    "Download Content

    You have not yet downloaded content for English.

    Do you want to download it now?"

    And when i click "Yes", I'm taken to the Add or Remove Content window. But, I'm unable to figure out what I have to download as there are a lot of options. Hope you suggest a fix to this problem.

    Regards.

    Thursday, June 09, 2016 10:13 AM
  • Hi Jain,

    From you description, the cause of this issue is that you didn't download the documentation and you couldn't open those link.

    Normally, you could install the .NET Framework related documentation, besides, you could install some other resource about language development according to the project you need.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Friday, June 10, 2016 6:30 AM
    Moderator
  • Can you please be more specific about what to download because I have already downloaded the documentation yet it is not working.

    Regards.

    Thursday, June 16, 2016 6:34 AM
  • Hi Brijesh Jain,

    You could tell us which link you tried to open, we can do a test on our side to see what documentation need to download.

    Or you may install all the documentation if your local space is available.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Thursday, June 16, 2016 6:55 AM
    Moderator