locked
macros use RRS feed

  • Question

  • I save my created macros under my Personal Workbook.  It seems somehow this has been closed and is not automatically reopening when I restart Excel.  How can I locate and reopen my personal workbook?
    Thursday, October 20, 2011 1:44 PM

Answers

  • I guess you can try...

    1. click office button
    2. click excel options
    3. advanced
    4. at startup, open all files in C:\Users\UserName\AppData\Roaming\Microsoft\Excel\XLSTART

    since I can't re-create the issue I don't know is it will work.

    • Marked as answer by Bruce Song Wednesday, November 2, 2011 5:41 AM
    Thursday, October 20, 2011 8:09 PM

All replies

  • C:\Users\UserName\AppData\Roaming\Microsoft\Excel\XLSTART
     Some other helpful tips on the personal Workbook can be found here

    http://www.rondebruin.nl/personal.htm

    Thursday, October 20, 2011 2:05 PM
  • Paste the following in the Immediate window (ctrl-g) and hit enter

    ?application.StartupPath

    If not there do a file search in Explorer, Personal.xls*  (will be .xlsb in 2007+)

    Maybe start again, record a macro, ensure you choose the option to create the macro in Personal, click a different cell, stop the macro, close Excel, accept the prompt to save Personal.

    Restart Excel, check your Personal has opened (look in the VBE), remove the dummy macro, Close Excel and again accept the save prompt

    Peter Thornton

    Thursday, October 20, 2011 2:49 PM
  • I tried recording a new macro and chose the personal workbook to save it in and got an error message that says:

    Personal Macro Workbook in the startup folder must stay open for recording

    --but i have no idea how to get it back open

    i did a search as well for the personal file and the computer isnt finding it

    Thursday, October 20, 2011 4:55 PM
  • thank you, that was very helpful, i was able to locate the file  :D

     

    the only problem is when i open existing sheets and try to pull up the personal workbook for macros, it still doesnt show up as a workbook to choose from

    Thursday, October 20, 2011 5:16 PM
  • how can i get it back to where it automatically opens with my excel worksheets like it used to?
    Thursday, October 20, 2011 5:17 PM
  • I guess you can try...

    1. click office button
    2. click excel options
    3. advanced
    4. at startup, open all files in C:\Users\UserName\AppData\Roaming\Microsoft\Excel\XLSTART

    since I can't re-create the issue I don't know is it will work.

    • Marked as answer by Bruce Song Wednesday, November 2, 2011 5:41 AM
    Thursday, October 20, 2011 8:09 PM
  • Hi SMasonUPSFreight,

    I am writing to check the status of the issue on your side. What do you mean "when pull up the personal workbook for macros, it still doesnt show up as a workbook to choose from"? When you try to open the workbook for macros, do you get any erros or any messages? Could you please describe more detail steps for us to reproduce this issue?

    Have a nice day.

    Best regards


    Liliane Teng [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, October 27, 2011 9:18 AM