none
Azure ML not processing all records RRS feed

  • Question

  • Hello all, 

    This is probably a very silly question so I apologize in advance, I have created a model in Azure ML and it's working well enough. When I process my data set i only get a partial output of the data. For instance i have a dataset with 35,000 records as the Input and the Output I have about 8,500 records. When I look at a recordset of a product across each month I see in the Input that i see all 12 months and in the output i see only 4 months. In the model i do split the data but I don't think that would impact. I'm not sure what i am missing and i can't seem to find much traction. This is my first full model i'm building.

    Thank you,

    Tuesday, August 27, 2019 12:52 AM

Answers

All replies

  • Hi orangeatom,

    It is not so clear, can you please let us know all the steps you have implemented in the model with the split condition and more about the data with all the columns those you are using in the model.


    Cheers,


    • Edited by Amit-Tomar Tuesday, August 27, 2019 1:36 AM
    Tuesday, August 27, 2019 1:36 AM
  • Hi, It is anomaly detection and in the dataset I have a flag that is a 1 for normal and a 2 for outlier. I'm actually using the template model here: 

    https://gallery.azure.ai/Experiment/1219e87f8fb84e88a2e1b54256808bb3


     and i am using the SVC method and have removed the PCA model.

    I can confirm for one recordset (specific product/item etc), that in the input there are 19 records (i used the sql transformation) and when i run the model and output there are 5 of that same recordset.

    The dataset looks like this, date, product, zipcode, customer, quantity, quantity stdev, quantity +3*stdev, quantity -3*stdev, quantity stdev category (1 if outlier for -3*stdev, 2 if normal, 3 if outlier for +3*stdev) - This is my label column. and I am using the above template.

    I hope that is enough information so far, i will try to simplify this further and run it again

    Thank you,


    Tuesday, August 27, 2019 11:15 AM
  • I figured out my silly question, I needed to publish and consume the model... I wasn't executing at the right stage. all solved.
    Tuesday, August 27, 2019 5:46 PM