The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Azure App Service - API Apps!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 none
Adding API App Host to Virtual Network fails RRS feed

  • Question

  • I've been trying for 2 days now to add an existing API App Host to a Virtual Network, but it errors with notification "VPNNetworkSetupFailure" and then the blade continues to say "Something went wrong" in the Networking tile.  The API App is DTSharedDimensions in subscription 8bc2fde5-e1ad-4bc0-9287-85957096f0b4.  Any help will be appreciated.

    On another note - the API App blade doesn't list any API Apps, I have to go to the App Service Plan blade and navigate from there to the API App and the API App Host.


    Thursday, April 9, 2015 11:04 PM

All replies

  • We've made a good number of portal improvements and fixes since the original post was submitted. Could you try this again and see if the problem persists? If so, please let us know on the forum, if not please let us know the problem has been mitigated. Thanks!
    Tuesday, May 26, 2015 9:28 PM
    Moderator
  • Problem still persists:

    {"error":{"code":"InvalidDeployment","message":"The provided deployment name 'InstallCertForWebsite-microsoft-apiappbf3bfb602dd0457f82e2c34e4f662ab2' has a length of '70' which exceeds the maximum length of '64'."}}

    And no way to change the api app host name.


    Wednesday, June 10, 2015 3:21 PM
  • Hi,

    We have the same issue. Is there any update?

    Thanks so much!


    Carlos Suárez

    Thursday, July 9, 2015 8:46 PM