none
Compiled .EXEs not launching

    Question

  • I have a few .NET solutions started, and when I run and debug them from within Visual Studio, everything works fine. When I start one from the .EXE itself, however, the program never launches.

    In Task Manager, I see something like the following

    MyTask.exe *32 112K

    MyTask.exe *32 112K

    MyTask.exe *32 112K

    These tasks cannot be killed unless I reboot.

    Any ideas?

    Thanks.

    Monday, January 18, 2016 4:40 AM

Answers

  • Hi Perdeid0,

    Thanks for your post.

    Could you tell me what’s your Windows OS and what’s your machine’s configuration?

    Please tell me the version of your Visual Studio as well.

    Please try to restart your machine then try it again.

    In addition, I suggest you’d better close the firewall and the anti-virus software or other third party processes then try it again.

    Please also  try to create a new .exe file and open it?

    For example, create a new WPF application and build it. Then double click the .exe. Check whether you could launch it.

    1. If can’t open a new created .exe. I suppose there was something wrong with your Visual Studio.

    In this case, try to repair your Visual Studio or install the latest update for your Visual Studio.

    For example: if you are using VS2013, install VS2013 Update5. If you are using VS2015, install VS2015 update1.

    2. If you can successfully launch the new created .exe. In this case, I suppose the problem is in your project.

    Check your project itself and rebuild it again. If still no help, I suggest you could create a new solution and add a same type project and copy files into it then try it again.

    Best Regards,

    Lake Xiao
    • Proposed as answer by lake XiaoModerator Wednesday, January 20, 2016 9:36 AM
    • Marked as answer by Perseid0 Friday, January 22, 2016 4:29 AM
    Tuesday, January 19, 2016 5:33 AM
    Moderator

All replies

  • Hi Perdeid0,

    Thanks for your post.

    Could you tell me what’s your Windows OS and what’s your machine’s configuration?

    Please tell me the version of your Visual Studio as well.

    Please try to restart your machine then try it again.

    In addition, I suggest you’d better close the firewall and the anti-virus software or other third party processes then try it again.

    Please also  try to create a new .exe file and open it?

    For example, create a new WPF application and build it. Then double click the .exe. Check whether you could launch it.

    1. If can’t open a new created .exe. I suppose there was something wrong with your Visual Studio.

    In this case, try to repair your Visual Studio or install the latest update for your Visual Studio.

    For example: if you are using VS2013, install VS2013 Update5. If you are using VS2015, install VS2015 update1.

    2. If you can successfully launch the new created .exe. In this case, I suppose the problem is in your project.

    Check your project itself and rebuild it again. If still no help, I suggest you could create a new solution and add a same type project and copy files into it then try it again.

    Best Regards,

    Lake Xiao
    • Proposed as answer by lake XiaoModerator Wednesday, January 20, 2016 9:36 AM
    • Marked as answer by Perseid0 Friday, January 22, 2016 4:29 AM
    Tuesday, January 19, 2016 5:33 AM
    Moderator
  • I'm using VS 2015 Community on Windows 7 64. Turns out it was my virus checker. Avast's DeepScreen was stopping my .exes from launching.

    Thanks. :)

    Friday, January 22, 2016 4:29 AM