locked
File not found error is not fixed with analyze RRS feed

  • Question

  • When I run analyze it displays this error:

    Unable to open file 'd:\vssdatabases\auntminnieasp\data\P\papgaaaa.a'.
    File "d:\vssdatabases\auntminnieasp\data\P\papgaaaa.a" not found

    So I run the suggested repair command.  Analyze says it found and fixed some errors, but when I start SS as "admin" I still get this error:

    File "d:\vssdatabases\auntminnieasp\data\P\papgaaaa.a" not found

    If I run Analyze again, it still has the same "file not found" error.

    Any suggestions on how to correct this?

     

     

     

    Friday, August 25, 2006 3:48 PM

Answers

  • First, please verify whether the file actually exists on the filesystem.  If so, it's likely a network error.  If not, you have database corruption.

    Is this with VSS2005 or 6.0d?  If available, I'd run the 2005 version of analyze with -f and -c to rebuild the database.  If the corruption remains, you need to either restore a backup or contact Customer Support.
    Monday, August 28, 2006 12:52 PM
    Moderator
  • Thanks for the help.

    For the record: adding the "-c" to the command line made the difference.

    Monday, August 28, 2006 4:15 PM

All replies

  • First, please verify whether the file actually exists on the filesystem.  If so, it's likely a network error.  If not, you have database corruption.

    Is this with VSS2005 or 6.0d?  If available, I'd run the 2005 version of analyze with -f and -c to rebuild the database.  If the corruption remains, you need to either restore a backup or contact Customer Support.
    Monday, August 28, 2006 12:52 PM
    Moderator
  • Thanks for the help.

    For the record: adding the "-c" to the command line made the difference.

    Monday, August 28, 2006 4:15 PM