locked
Windows 8 hyper-v on Intel i7 2600K doesn't seem to work

    Question

  • I am wondering if anyone has gotten hyper-v to work on a Sandy Bridge i7 2600K and Windows 8. I am getting a error telling me Hypervisor is not running when I look in Event Viewer I get an error

    The virtualization infrastructure driver (VID) is not running.

    When I am in device manager it tells me that this driver is functioning normally. I know hyper-v works I have seen it working on a students laptop with an AMD Cpu.

    Wednesday, September 21, 2011 9:55 PM

Answers

  • After doing some more research it looks like the intel video driver might be the issue. Tried installing an old driver and that didn't help. The device that maps back to hyper-v is Microsoft Device Association Root Enumerator when I click on event view this takes me to Hyperv-VMMS.

    At least I now know what the issue is.

     

    Thursday, September 22, 2011 11:05 PM

All replies

  • Is your UEFI firmeware of the motherboard update to date? Also check that VT is enabled in the BIOS.
    "A programmer is just a tool which converts caffeine into code"

    Wednesday, September 21, 2011 10:07 PM
  • There is an update to for the BIOS and VT is enabled Windows 7's XP mode is working for me.

     

    Will try the BIOS update and see what happens.

     

    Thanks

    Wednesday, September 21, 2011 11:03 PM
  • Updated the UEFI Firmware and this didn't solve the issue. Still get the same error above. Will keep playing but I am thinking that an update to Hyper-v will be needed.
    Thursday, September 22, 2011 8:54 PM
  • After doing some more research it looks like the intel video driver might be the issue. Tried installing an old driver and that didn't help. The device that maps back to hyper-v is Microsoft Device Association Root Enumerator when I click on event view this takes me to Hyperv-VMMS.

    At least I now know what the issue is.

     

    Thursday, September 22, 2011 11:05 PM
  • Run BCDEdit and look if you see this entry:

    hypervisorlaunchtype    Auto

    if not, add it with BCDEdit.


    "A programmer is just a tool which converts caffeine into code"

    Friday, September 23, 2011 4:10 PM
  • The entry in my system looks like this.

    hypervisorlaunchtype    Auto

    Same thing you have above.

    My current setup works in Windows 7 I can run xp mode in windows 7 with no issue.

    Anyway it isn't a big deal this will be an awesome feature in Windows 8.

     

    Friday, September 23, 2011 8:10 PM
  • Windows VirtualPC / Windows XP Mode can run without VT enabled.  If it works, there's no guarantee that Hyper-V will work with the same BIOS settings.  (See here: http://support.microsoft.com/default.aspx?scid=kb;EN-US;977206 for more details).

     

    It sounds like there's still a BIOS setting that's preventing Hyper-V from working correctly.  Can you confirm these settings are enabled: Intel VT-x (Virtualization Technology), Execute Disable (Data Execution Prevention), and that the following setting is disabled: Intel TXT (Trusted Execution)?  After changing the settings, please make sure you fully power off the system - a reboot is not enough.

     

    Also, could you post your motherboard or system model?  There's a chance someone could share more details on the BIOS settings needed.  Sometimes the settings are renamed or difficult to locate.

    Monday, October 3, 2011 5:37 PM