none
EDI splitting into multiple files RRS feed

  • Question

  • Hi All,

    I am using 837P 5010 multiple schema for importing EDI 5010 files into BizTalk and export to a custom format of my own. When i upload a particular file alone, the custom output file is splitting into multiple files(to be exact its 3 output files). I looked into the EDI file and it seems the GE trailer segment has the count of ST's and SE's in the file. Ex: GE*3*101455

    I thought this is causing the file to split into multiple files, so i manually changed the GE segment value to GE*1*101455, but still i am getting the same result i.e splitting into 3 files :(

    Then i did more analysis and found that each ST02 and SE02 is having unique values

    EX: 

    ISA*.....

    GS*...

    ST*837*123

    ...

    SE*23*123

    ST*837*1234

    ...

    SE*24*1234

    ST*837*12

    ..

    SE*122*12

    GE*

    IE*

    so my question is this the correct behaviour or do i need any change to get the output file as 1 file.... please let me as soon as possible... i need this go to my prod environment by this week end.

    Thanks in advance

    Venkat

    Tuesday, February 21, 2012 5:16 PM

All replies

  • Biztalk debatch it depending upon number of ST and SE..

    If you want to get one output files......you need to change the agreement setting under party ....under the local host setting change from split interchange-suspend transaction sets on error  to preserve interchange-suspend interchange on error....


    And also you need to use single schema as said by Carlos...Multiple schema debatched it depending on number of claims...



    • Edited by sriaug Tuesday, February 21, 2012 6:29 PM
    Tuesday, February 21, 2012 5:30 PM
  • If your output is for one single file, you need to use the single schema. Did you try that?

    Please Indicate "Mark as Answer" if this Post has Answered the Question

    Tuesday, February 21, 2012 5:30 PM
  • i tried the change and i am getting invalid number of transactions error :(

    Tuesday, February 21, 2012 6:21 PM
  • sorry for the mistake, i got confused with the single and multiple schema... i just verified and i am using single schema only... 
    Tuesday, February 21, 2012 6:21 PM
  • Then change the party setting....
    Tuesday, February 21, 2012 6:25 PM
  • sriaug,

    i did the change for that i am getting invalid transaction error... 

    Tuesday, February 21, 2012 6:31 PM
  • can you tell me the error in the event log......nd do not change the value of GE*3 to GE*1


    • Edited by sriaug Tuesday, February 21, 2012 6:34 PM
    Tuesday, February 21, 2012 6:34 PM


  • Functional Group Error Information


    Sequence No: 1
    Functional Id: HC
    Control Number: 101455


    Functional Group Errors


    Error: 1 (Miscellaneous error)
    5: Number of included transaction sets do not match

    Tuesday, February 21, 2012 6:36 PM
  • this error is due to value of first element fo GE........

    It should match the count of ST and SE..........

    I think you have 3 ST to its value should be GE*3

    Tuesday, February 21, 2012 6:40 PM
  • yes i have 3 ST & SE in my file...

    this is the format i have it in my file, except i have changed the values

    ISA*.....

    GS*...

    ST*837*123

    ...

    SE*23*123

    ST*837*1234

    ...

    SE*24*1234

    ST*837*12

    ..

    SE*122*12

    GE*

    IE*

    Tuesday, February 21, 2012 6:43 PM
  • just make sure you restart the host instance....changes will take into effect when you restart the host instance.........nd if this is the format of your file.

    then GE*3 is correct..

    Tuesday, February 21, 2012 6:48 PM
  • i did restart... but still the same... so the behaviour to get 3 output files is correct ?
    Tuesday, February 21, 2012 6:56 PM
  • yes.......biztalk debatch it depending on number of ST and SE.....that behaviour is correct.
    • Marked as answer by Venkatesannn Tuesday, February 21, 2012 6:59 PM
    • Unmarked as answer by Venkatesannn Tuesday, February 21, 2012 7:00 PM
    Tuesday, February 21, 2012 6:58 PM
  • one last question before marking as answer... is there a way to make the change to output as single output ?
    Tuesday, February 21, 2012 7:01 PM
  • yes when you change the agreement setting under the party and change it to the preserve interchange- you will get one file.....can you mail me your input file  . i will look into the file.... i had the same situation last week and changing the agreement setting worked for me....


    • Edited by sriaug Tuesday, February 21, 2012 7:18 PM
    Tuesday, February 21, 2012 7:03 PM
  • i am sorry sriaug, our emails are tracked very sentively.. so its difficult for me to send it... i will try to scramble it and may be i will try to send it.. if not please let me how to proceed further... thank for understanding..
    Tuesday, February 21, 2012 7:20 PM
  • can you just post your ISA,GS,GE,IE ,ST,SE value exactly.  you can change the ISA 6,7,8,9 for security......


    • Edited by sriaug Tuesday, February 21, 2012 7:29 PM
    Tuesday, February 21, 2012 7:28 PM
  • sure...


    ISA*00*          *00*          *ZZ*123655650      *01*12345          *120202*1820*|*00501*000101455*0*P*:~GS*HC*12345678*123456789*20120202*1820*101455*X*005010X222A1~


    ST*837*12345678*005010X222A1~...~SE*35*45633337~ST*837*212345678*005010X222A1~....~SE*43*12345678~


    ST*837*12345678*005010X222A1~....~SE*34*23456789~GE*3*101455~IEA*1*000101455~


    Tuesday, February 21, 2012 7:32 PM
  • Hi Venkatesannn,

    I just tried using your ISA,GS,ST,SE,GE, and IEA

    i just made change in Party setting i changed it to preserve interchange and it worked for me......

    earlier it was giving 3 xml file...nd when i changed the party setting it gave me 1 xml file...

    are you sure your party setting is correct.......just check with party settings...

    here is the segments i used....nd i put some dummy data in between...

    ISA*00*0000000000*00*0000000000*ZZ*123849543      *ZZ*173443586      *120202*1820*|*00501*000101455*0*P*:
    GS*HC*123849543*173443586*20120202*1820*101455*X*005010X222A1
    ST*837*27936147*005010X222A1
    SE*31*27936147
    ST*837*27949039*005010X222A1
    SE*31*27949039
    ST*837*27973155*005010X222A1
    SE*31*27973155
    GE*3*101455
    IEA*1*000101455


    • Edited by sriaug Tuesday, February 21, 2012 8:20 PM
    Tuesday, February 21, 2012 8:09 PM
  • Correct if i am wrong...

    Parties-> Party1 -> right click EDI properties ->x12 properties -> party as interchange sender -> inbound batch processing option -> preserve interchange - suspend interchange on error (3rd option) right ?

    Tuesday, February 21, 2012 8:20 PM
  • also all other values should match exactly like ISA 6,7,8,9,11 and GS Segment setting should match exactly with the agreement......

    and also just change the send pipeline to passthrough pipeline......


    • Edited by sriaug Tuesday, February 21, 2012 8:22 PM
    Tuesday, February 21, 2012 8:21 PM
  • did it worked..or still facing issues
    Tuesday, February 21, 2012 8:40 PM
  • still the same... will try to see clearly once more and will get back to you
    Tuesday, February 21, 2012 8:41 PM
  • Venkatesannn, did you fix this?  I am seeing the same behaviour too.
    Tuesday, March 13, 2012 10:28 PM
  • no, i still could not figure out the solution, temporarily the change is accepted by the team.
    Thursday, March 15, 2012 3:43 PM
  • Venkatesannn, what is that temporary change?  can you share, please?

    Thursday, March 15, 2012 11:39 PM
  • hi BooTalk, i meant the multiple files are accepted by the team, sorry for not providing clear information.
    Friday, March 16, 2012 2:52 AM