locked
Sharepoint 2013 Document Library Search Doesn't Work RRS feed

  • Question

  • Hi friends.

    I've created a SharePoint 2013 Document Library  with some folders and files.

    When i try to search in the document library by document name or any column (Created Date, Comments, etc) the search says that don't have results.

    In the library settings i've enabled Advanced Settings->Allow Items from this document library to appear in search results? Yes but dont work.

    What i should to do? 


    Regards
    Monday, October 6, 2014 2:06 PM

Answers

  • First check search topology:

    1. In CA, go: General Application Settings > Search > Farm Search Administration > Search Service Applications > Search Service
    2. Look in the Search Application Topology section
    3. Verify that there are green checks for all search components on all servers
    4. In the Quick Links, click Crawl Log
    5. Verify that crawls are occuring regularly. If no crawl have occurred, perform a manual crawl and schedule full and increment crawls.

    Second, check index update.

    1. Navigate to the document library
    2. Go to Document library Advanced Settings
    3. Scroll down to the Re-index Document Library
    4. Click the button. Reindex Document Library
    5. Click OK
    6. Launch an Incremental crawl.
    7. Perform a search again
    • Marked as answer by DANIELVIVAS92 Monday, October 6, 2014 3:44 PM
    Monday, October 6, 2014 2:17 PM

All replies

  • First check search topology:

    1. In CA, go: General Application Settings > Search > Farm Search Administration > Search Service Applications > Search Service
    2. Look in the Search Application Topology section
    3. Verify that there are green checks for all search components on all servers
    4. In the Quick Links, click Crawl Log
    5. Verify that crawls are occuring regularly. If no crawl have occurred, perform a manual crawl and schedule full and increment crawls.

    Second, check index update.

    1. Navigate to the document library
    2. Go to Document library Advanced Settings
    3. Scroll down to the Re-index Document Library
    4. Click the button. Reindex Document Library
    5. Click OK
    6. Launch an Incremental crawl.
    7. Perform a search again
    • Marked as answer by DANIELVIVAS92 Monday, October 6, 2014 3:44 PM
    Monday, October 6, 2014 2:17 PM
  • Check if you document library is enabled to search.

    Make sure that a full crawl is turned on over the library.

    goto library settigns ==> advanced settings .

    Also check for content approval is disabled or if enabled make sure all documents are approved .

    under this we can find the lib settings--> versioning stetting  enable or disable content approval.

    look in search service  log to look if the items are picked up by the crawl.

    If not try recrawl.

    Monday, October 6, 2014 2:33 PM
  • my problem is that:

    my site owner can search and returned results from 'search within document library"

    but my visitors can not search, and no result returned, anything wrong with permission?

    Tuesday, November 10, 2015 6:15 PM
  • Do these checks:

    1. Check that these users have the permission to view documents in this folder.  You may need to check permissions at the site level, document library level and at the document level.
    2. Check library Advanced Settings and verify that items in this library are allowed to appear in search results.
    3. Perform a full crawl and then to see if the problem persists.
    4. Check that the Search Service application is started
    5. Check server services and verify that the Search Host Controller and Server Search 15 services are started.
    Tuesday, November 10, 2015 6:30 PM