none
[Node.js][Web Apps] npm install receives RPC failed error RRS feed

  • Question

  • I've created a React Web Starter Kit project which runs successfully on my local Windows 10 box.  I have followed directions to publish my web app to Azure.  I also followed directions to have Azure's Kudu run a custom script for installing and building my app.

    When my custom deployment executes (git push azure master), it spends several minutes running an 'npm install' command and then gives an error:

    remote: Preparing deployment for commit id '22fbf15693'.
    remote: Running custom deployment command...
    remote: Running deployment command...
    remote:
    remote: D:\home\site\repository>call npm install
    remote: ..................error: RPC failed; result=56, HTTP code = 200
    fatal: The remote end hung up unexpectedly
    error: error in sideband demultiplexer
    Everything up-to-date

    What might be causing this? How can I resolve this?  My custom script looks like this:

    call npm install 
    IF "%ERRORLEVEL%" NEQ "0" goto error
     
    call npm run build
    IF "%ERRORLEVEL%" NEQ "0" goto error
     
    del /q %DEPLOYMENT_TARGET%\*
    for /d %%x in (%DEPLOYMENT_TARGET%\*) do @rd /s /q "%%x"
    IF "%ERRORLEVEL%" NEQ "0" goto error
     
    xcopy %DEPLOYMENT_SOURCE%\build %DEPLOYMENT_TARGET% /Y /E
    IF "%ERRORLEVEL%" NEQ "0" goto error
     
    goto end
     
    :error
    endlocal

    -Brent Arias





    Monday, January 11, 2016 6:32 AM

Answers

  • Evidently I merely needed to retry, and it worked fine.  In other words, I simply ran "git push azure master" again from my machine and it simply worked the second time around.  Problem solved.

    -Brent Arias

    • Marked as answer by Brent Arias Monday, January 11, 2016 7:10 AM
    Monday, January 11, 2016 7:03 AM