locked
"System.Data.OracleClient requires Oracle client software version 8.1.7 or greater." error message? RRS feed

  • Question

  • User-1970482731 posted
    This error often occurs with our team, this seemed a .NET (or Oracle bug) because we can fix it (not always) with some security tricks. Does it has happened with your applications, and how to fix? Thanks, p.s: .NET 1.0, SP2, Oracle 9i 9.0.2 (both client/server).
    Wednesday, September 3, 2003 12:10 AM

All replies

  • User1349123926 posted
    Hi, Version 9.0.2? Are you running iAS as well? "Normal" oracle versions are 901, and 920 (although 902 is some sort of "special" version that comes with iAS). If using 920, its not "security tricks" you're doing. Its the real fix. The default 920 install permissions were botched, and thats the legitimate solution. It is my understanding that the "botched permissions" is specific to 920, and didnt occur in previous versions anyway (but could certianly occur if your sysadmin was a little overzealous in locking things down). Cheers, Greg
    Wednesday, September 3, 2003 10:45 AM
  • User-1970482731 posted
    Thanks, but how to fix it?
    Monday, September 8, 2003 2:33 AM
  • User1349123926 posted
    Solution Description -------------------- Oracle 9.2 Client software requires that you give the Authenticated User privilege to the Oracle Home by following these steps: 1. Log on to Windows as a user with Administrator privileges. 2. Launch Windows Explorer from the Start Menu and and navigate to the ORACLE_HOME folder. This is typically the "Ora92" folder under the "Oracle" folder (i.e. D:\Oracle\Ora92). 3. Right-click on the ORACLE_HOME folder and choose the "Properties" option from the drop down list. A "Properties" window should appear. 4. Click on the "Security" tab of the "Properties" window. 5. Click on "Authenticated Users" item in the "Name" list (on Windows XP the "Name" list is called "Group or user names"). 6. Uncheck the "Read and Execute" box in the "Permissions" list under the "Allow" column (on Windows XP the "Permissions" list is called "Permissions for Authenticated Users"). 7. Re-check the "Read and Execute" box under the "Allow" column (this is the box you just unchecked). 8. Click the "Advanced" button and in the "Permission Entries" list make sure you see the "Authenticated Users" listed there with: Permission = Read & Execute Apply To = This folder, subfolders and files If this is NOT the case, edit that line and make sure the "Apply onto" drop-down box is set to "This folder, subfolders and files". This should already be set properly but it is important that you verify this. 9. Click the "Ok" button until you close out all of the security properties windows. The cursor may present the hour glass for a few seconds as it applies the permissions you just changed to all subfolders and files. 10. Reboot your computer to assure that these changes have taken effect.
    Monday, September 8, 2003 11:11 AM
  • User-153615472 posted

    Hi Greg

    Thanks for the detailed response. Sorry to bother you

    These permissions  changes were to be made on data server you are connecting to right ?

    The "Authenticated Users" item was not listed as you suggested in 5 above so I added it by selecting "Add " then typying Auth and "checknames".

    It found "Authenticated Users" so then I addedd it and set the permissions as you suggested above.

    One thing I couldn't do was reboot the server, kinda not allowed as it's use in production.

    I'm still getting the error when trying to connect to the database from my aspx.

    does the server definatley  have to be reboted or do you think iIve made soem other mistake.

     

    many thanks

    Aido 

     


     

     

     

     

    Tuesday, November 28, 2006 8:10 AM
  • User-1623675128 posted

    Hi 

    the following thing also cause for this error try to check following things tooo...

    If you are using asp.net 1.1 then go to your machine.config file and in process model section try to chnage user name as "system";

    if you are in 2.0 version do the same thing some times you might not find the process model section at all then try add the same section it self.

    hope it will help you out.....

    Wednesday, December 6, 2006 4:20 AM
  • User1267835458 posted

    install oracle data provider for .NET in oracle 9.2.0.7

    Wednesday, November 14, 2007 10:19 AM
  • User493555100 posted

    Hello All,

    I am still facing this problem. I changed the user permissions also and do all wat you guyz said.

    Tell me one thing......... Where is machine.config file so that i can update it.

     

    Thanks in Advance

    Monadear 

    Tuesday, April 8, 2008 7:52 AM
  • User-1623675128 posted

    you can find out the mahine.coinfig file in the following location:for 2.0 version i think u are using 2.0

    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONFIG

    Wednesday, April 9, 2008 12:15 AM
  • User1325084196 posted

    [:)] Thanks .. This solution followed by reboot solved the issue

    Wednesday, May 14, 2008 3:44 AM
  • User919072903 posted

    Hi Ramana123,

     

    Thanks a ton for posting this because we have waste two complete days in trying to understand and resolve this issue.... :) ..

    Thursday, May 12, 2011 5:59 AM
  • User513343892 posted

    Hi,

    I am using .Net framework 2.0 and installed oracle client 11.2.0 in my server.

    I'm trying to connect to an oracle database from my AP.net web application. the open connection method is failing with the following exception:

    System.Data.OracleClient requires Oracle client software version 8.1.7 or greater

    But i have already installed oracle client.

    Can any one please help me ion fixing ths issue.

    Thanks,

    Suneel k  R

    Thursday, June 16, 2011 2:46 AM
  • User513343892 posted

    Hi,

    The issue was,The firewal is not opened to connect to the oracle databse in the server in which the application is hosted.

    Once the firewall is opened i was able to connect to oracle database.

    Wednesday, June 22, 2011 6:47 AM
  • User513343892 posted

    hI guys, Problem again started. I was able to telnet to the server but if i access through the .Net 2.0 webapplication i'm getting the same error.

    Can anyone plss help me...

    Monday, June 27, 2011 9:47 AM