Classic ASP Not Installed by default... RRS feed

  • Question

  • User1216627406 posted

    Greetings mates,

    As a disclaimer, I posted this question on General forum on forums.asp.net but I was asked to ask the question here.

    First, I did not find a forum for classic ASP. So, I hope that posting on this General ASP.NET will suffice. I searched and noticed some posts about classic ASP answered here.

    Please forgive me if I am wrong. That said,

    We have a web app built on classic ASP (It was built long before I joined the organization and they have refused to allow us to rewrite in asp.net.

    This web allows users to perform searches about their properties.

    They perform this search using parcel IDs.

    There are literally thousands of parcels on our DB and they load correctly when searched by parcel ID except just one.

    When you search with this one, it gives server 500 error, the resource you are looking for cannot be found.

    To expose the error more explicitly, I had to enable Detail Error messages on IIS.

    After exposing this error, I tried searching with the parcel ID again, it displays the message but also displayed the following error:

    An error occurred on the server when processing the URL. Please contact the system administrator.

    If you are the system administrator please click here to find out more about this error.

    When I clicked on the here link, I was taken to a page that says:

    Classic ASP Not Installed by Default on IIS 7.0 and above

    The page basically walks you through the process of installing ASP and especially ISAPI extensions.

    Problem is that these features are already installed as the checked boxed indicated.

    Now, I am stuck trying to figure out this error.

    Does anyone know what else could be done to resolve this error?

    I for one do not think the issue is code-related. However, if someone needs some snippets, I will be glad to post some.

    As stated, this app has been working for ages without issues. So, I am very confident it is not a code issue.

    Any assistance is greatly appreciated.

    The individual that supports this classic ASP app is on vacation for a month and I am his back.

    Thanks in advance for your assistance.

    Friday, November 2, 2018 12:47 AM

All replies

  • User-72702933 posted

    Hi simflex,

    Could you please post the corresponding handler mappings entry for asp requests. The settings could be found in applicationHost.config(located at %windir%\system32\inetsrv\config), and looks like the following:

    <add name="ASPClassic" path="*.asp" verb="GET,HEAD,POST" modules="IsapiModule" scriptProcessor="%windir%\system32\inetsrv\asp.dll" resourceType="File" />

    Also please check isapi restrictions settings has asp allowed, ensure the following setting exist in isapiCgiRestriction section:

    <add path="C:\Windows\system32\inetsrv\asp.dll" allowed="true" groupId="ASP" description="Active Server Pages" />

    Best Regards,


    Monday, November 5, 2018 3:08 AM