locked
Cannot install any CU RRS feed

  • Question

  • Hi,

    I'm using SharePoint 2013 Server. When I run (Get-Spfarm).Buildversion , it gives me 15.0.4701.1000

    I tried to install (April 2015 CU) , (May 2015 CU), (November 2015 CU). It didn't work because it doesn't find the right version number. So I run the update with : PACKAGE.BYPASS.DETECTION.CHECK=1

    The install run fine, then I ran the psconfig.exe . (by the way the databases shows as no upgrade is required). When it's finished, I run again the (get-spfarm).Buildversion and it gives me the same version as before: 15.0.4701.1000

    Any idea what is wrong here? Any help is much appreciated.

    Thank you.


    -Mehdi

    Friday, January 29, 2016 2:58 AM

Answers

All replies

  • Have you installed Service Pack 1 for SharePoint and any LPs? You should never have to use (nor should you) bypass detection.

    Trevor Seward

            

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, January 29, 2016 3:24 AM
  • Hi,

    Service pack 1 is installed yes.

    I found that some LP are installed (Arabic, Russian etc...) Not sure where it's coming from, and I can't find a way to remove it. (not sure if that's what causing it not to upgrade)


    -Mehdi

    Friday, January 29, 2016 3:34 AM
  • You can uninstall those from Programs and Features in the Control Panel on each SharePoint server, or update them to SP1.

    Trevor Seward

            

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, January 29, 2016 3:35 AM
  • I don't think it's LPs that are installed, it doesn't show any LP under Programs and Features.

    On SharePoint Admin Console, when I go to the patches, I see something like this: Microsoft Server Proof (German) 2013.

    And other languages shows as Microsoft Server Proof (Language)


    -Mehdi

    Friday, January 29, 2016 3:53 AM
  • Any other ideas guys?

    I really could use some help on this.

    Thank you.


    -Mehdi

    Saturday, January 30, 2016 5:05 PM
  • What is the status of every server on Manage Servers on Server page? Run SharePoint products wizard and make sure it finishes without any errorl

    Query the Configuration Database Version Table (Only if this is a Non Production Farm)

    Select * from Versions

    paste the values here.


    Jerry Yasir - Office Server & Services MVP/MCT Hewlett Packard Enterprise If this reply helped you resolve your issue, please propose as answer.

    Sunday, January 31, 2016 3:58 AM
  • Hi,

    On manage server it seems that there is no issue on the server (We are using only 1 SharePoint server).

    It is a production farm.


    -Mehdi

    Sunday, January 31, 2016 4:36 PM
  • Hi Mehdi,

    Please check from central admin > Upgrade and migration > Check product and patch installation status, make sure your KB2965261 is mentioned over here as installed.

    Running command PSConfig.exe -cmd upgrade -inplace b2b in PowerShell.

    A similar thread for your reference:

    http://sharepoint.stackexchange.com/questions/141943/installed-april-cu-but-build-version-did-not-change

    Best Regards,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, February 1, 2016 7:25 AM
  • Hi,

    KB2965261 this is for sharepoint foundation not sharepoint server.

    I did run PSConfig.exe -cmd upgrade -inplace b2b in PowerShell after I installed the CU and no database is showing as requiring upgrade.


    -Mehdi

    Monday, February 1, 2016 3:49 PM
  • Hi Mehdi,

    Go to "Check product and patch installation status" to check if the CU installed is here.

    Then check "Review database status" to see if there are any database which needs to be updated.

    Please try to re-run the CU.exe, check if it could work.

    In addition, check ULS log to see if there is something about this issue.

    Best Regards,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, February 2, 2016 1:45 AM
  • Hi Wendy,

    The CU is not listed there.

    There is no database that needs an update.

    When I run the CU.exe again it says that it's not finding the expected version.


    -Mehdi

    Tuesday, February 2, 2016 5:10 PM
  • Hi Mehdi,

    There are some similar blogs about this issue, please check if they are useful for you:

    https://blogs.technet.microsoft.com/stefan_gossner/2015/04/14/common-issue-april-2015-fixes-for-sharepoint-2013-might-not-install-on-sharepoint-2013-sp1-slipstream-builds/

    https://mohamedelkassas.wordpress.com/2014/06/14/trying-to-install-a-update-you-get-the-expected-version-of-the-product-was-not-found-on-the-system/

    https://blogs.technet.microsoft.com/stefan_gossner/2013/11/20/common-error-message-the-expected-version-of-the-product-was-not-found-on-the-system/ (the troubleshooting steps are available for SharePoint 2013)

    Best Regards,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, February 3, 2016 7:00 AM