none
WCF Application only works after debugging RRS feed

  • Question

  • Hello,

    I am programming a WCF managed application that will be hosted in IIS. When i am testing this application the following problem occurs:

    I open the project, run without debugging i get EndPointNotFoundException. When i run with debugging de program exits with code 0x0. If i run without debugging after debugging once the program works fine, until i restart Visual Studio. Then i have to run debugging mode again. What dependencies are set when i run with debugging mode? How can i solve this?


    Thursday, April 23, 2015 7:43 AM

Answers

All replies

  • Hi Brianovitch93,

    Since it is related to the WCF app, I help you move this case to the WCF forum for dedicated support.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, April 24, 2015 5:57 AM
  • Hi Brianovitch93,

    In my mind, it may be because that you do not host the WCF Service in IIS very well. Because if we run the application in the debug mode, the Visual Studio will start a WcfSvcHost.exe for us to host our service, so the WCF Service will work. When we start without debugging, the WcfSvcHost.exe part is missing, so the service can not run.
    Besides, I will recommend you refer to the following articles about how to host WCF Services in IIS:
    https://msdn.microsoft.com/en-us/library/ms733766(v=vs.110).aspx .
    http://www.codeproject.com/Articles/550796/A-Beginners-Tutorial-on-How-to-Host-a-WCF-Service .

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Brianovitch93 Wednesday, April 29, 2015 2:06 PM
    Monday, April 27, 2015 2:15 AM
    Moderator
  • Thanks! I think this will do it, if i have a problem i will ask it here!
    Wednesday, April 29, 2015 2:05 PM