locked
'Could not load type' error when viewing a web app package on IIS RRS feed

  • Question

  • User1624967179 posted

    I am new to Visual Studio 2012 and the Web Deploy 3.0 used to upload a package to IIS. While my application compiles and renders fine on my local development laptop, when I package the web app and then import the packaged zip file to my site on IIS I get error when I try to view the page. When I open IE on my local machine and browse to my site address by IP (_http://1.2.3.4/acme/tools/default.aspx) I get this error "Server Error in '/' Application." and then further below "Parser Error Message: Could not load type 'ACME.Default'". The source error is pointing to my page declaration. It appears that it is having trouble with the 'Inherits="ACME.Default"' , but why? And how to fix?

    I have seen several questions online on various forums, but none fix my issue. I have tried the following with no success:

    • copying the entire bin folder to my IIS site directory
    • copying the ACME.default.aspx.cs file to accompany the ACME.aspx file
    • Made sure that I was using .Net framework 4 and not version 2
    • Tested the packaging of my site and improrted it to a second site and received the same error

    I'm stuck and I can't get up .... (light humor) :)

    Thanks,

    Alex

    Friday, May 31, 2013 1:41 PM

Answers

  • User1624967179 posted

    I opened a ticket with Microsoft and found some answers. There were incorrect configurations in my publishing process. After we fixed these issues the problem was fixed. When using the "Web Deploy 3.0" packaging interface, here were the steps I used:
    1. Publish method = Web Deploy
    2. Server = _https://servername:8172/msdeploy.axd
    3. Site Name = Default Web Site/mysitename

    (remove the _ underscore in the server https:)
    The port number was provided by the Microsoft tech. It is a standard port for publishing.
    I hope this helps someone else.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, June 3, 2013 1:26 PM