locked
Container missing after updateContainers

    Question

  • I am recieving an error "Container missing after updateContainers" when navigating between pages that have listview elements.  The code did not change from Windows 8 (which worked correctly) but now that I am targetting 8.1 I get this error after navigating back and forth between pages with listview controls.

    Thanks for any help.

    Wednesday, February 26, 2014 10:33 PM

All replies

  • Any reproducible demo?

    In general, if both pages only contains listview element, should not be any problem. Without seeing logic part, hardly to determine why this happens.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Thursday, February 27, 2014 6:52 AM
    Moderator
  • I ran into the similar issue where two of my pages contained ListView Items as well. It was more of a master/detail view. The issue was that even though I navigated away from the details page, the binding was still intact. When I reloaded the page again (after selecting an item from the master page) and attempted to clear out my binding list, it blew up with the error:

    "container missing after updatecontainers"

    1. In order to avoid that this is what I did, on the details page I:
    2. Set the itemDataSource of the listview to null
    3. Cleared my binding list
    4. Populated my binding list
    5. Set the itemDataSource back to the binding list.

    Hope this helps. I'm not sure if you have a different scenario, but this occurred because I was attempting to clear out my binding list before re-populating it.

    Saturday, March 29, 2014 1:52 AM