none
An error occured at deployment of windows application with crystal report of VS 2010. RRS feed

  • Question

  • HI,

    I am trying to develop a windows application using C# .NET. But, I am really new at C# developing language.

     

    I am using following conditions for developing this application:

    1. Visual Studio 2010 ultimate version

    2. Language: C#

    3. Framework: .NET 4.0 [not .NET 4.0 Client Profile]

    4. Compact Database 3.5 SP2

    5. Crystal Report for VS2010

    NOTE: I am using Windows 7 (64 bit OS)

     

    But, when i am trying to deploy this application using click-once option of VS, i got some errors. And i don't know how to solve this problems?

    The errors are following:

    Warning              1              The version of the .NET Framework launch condition '.NET Framework 4 Client Profile' does not match the selected .NET Framework bootstrapper package. Update the .NET Framework launch condition to match the version of the .NET Framework selected in the Prerequisites Dialog Box. 

    Warning              2              The 'SAP Crystal Reports Runtime Engine for .NET Framework 4.0' item selected requires 'Microsoft.Net.Framework.2.0'. Select the missing prerequisite in the Prerequisites Dialog Box or create a bootstrapper package for the missing prerequisite.  

    Warning              3              The 'SAP Crystal Reports Runtime Engine for .NET Framework 4.0' item selected requires 'Microsoft.Data.Access.Components.2.8'. Select the missing prerequisite in the Prerequisites Dialog Box or create a bootstrapper package for the missing prerequisite. 

    Error      4              The install location for prerequisites has not been set to 'component vendor's web site' and the file 'Crystal Reports for .NET Framework 4.0\CRRuntime_32bit_13_0_1.msi' in item 'SAP Crystal Reports Runtime Engine for .NET Framework 4.0' can not be located on disk. See Help for more information.

    Error      5              The install location for prerequisites has not been set to 'component vendor's web site' and the file 'Crystal Reports for .NET Framework 4.0\CRRuntime_64bit_13_0_1.msi' in item 'SAP Crystal Reports Runtime Engine for .NET Framework 4.0' can not be located on disk. See Help for more information.

    Error      6              General failure building bootstrapper

    Error      7              Unrecoverable build error

     

    Please, if any one can help me, it will be glad for me.

     

    Thanks in Advance

    MD. Mahmudur Rahman

    Thursday, September 8, 2011 7:53 AM

Answers

All replies

  • Just do following

    • Find a product.xml file in C:\\Program Files\Microsoft SDKs\Windows\v7.0A\Bootstrapper\Packages\Crystal Reports for .NET Framework 4.0\
    • Open the product.xml file in Notepad (or any text editor)
    • Under the <PackageFiles> section, find 2 URLs that point to the 2 deployment packages
    • Copy each URL into your web browser and manually download the packages
    • Once the packages are downloaded, copy them to the same folder as the product.xml file
    • Build and publish your ClickOnce deployment

    Or download Crystal Reports for .NET Framework 4.0 runtime version from following link

    http://downloads.businessobjects.com/akdlm/crnetruntime/clickonce/CRRuntime_32bit_13_0_1.msi

    http://downloads.businessobjects.com/akdlm/crnetruntime/clickonce/CRRuntime_64bit_13_0_1.msi

    Then past it to

    C:\\Program Files\Microsoft SDKs\Windows\v7.0A\Bootstrapper\Packages\Crystal Reports for .NET Framework 4.0\

    Then rebuild your solution

    Hope it will solve your problem.

     


    Hasibul Haque,MCC,MCPD blog.e-rains.com
    Thursday, September 8, 2011 8:10 AM
  • Thanks, it's works great...

    Now deployment is complete.

     

    Thursday, September 8, 2011 3:44 PM
  • Thanks, it's works great...

    Now deployment is complete.

     

    hI,As such. A query sequence as I can give & Miscellaneousbecause I get the following error when I install on the client.

    Could not install the SAP Crystal Reports Runtime Engine for. NET Framework 4.0 and appeared the following error message: "Fatal error during installation."

    DotNetFX40

    WindowsInstaller4_5

    Crystal Reports for. NET Framework 4.0

    I assume you start installing the Crystal Report and as it is the NETFramework 4.0 generates error.

    How I can manage a sequence of execution or automatic dependency.?
     
    Friday, November 25, 2011 4:46 PM
  • First install WindowsInstaller4_5 >> then DotNetFX40 >>then Crystal Reports for. NET Framework 4.0 (Consider 64 or 32 Bit).Can you give your error details


    Hasibul Haque,MCC,MCPD blog.e-rains.com
    Saturday, November 26, 2011 8:30 AM
  • Hi,

     

         I have created a Windows Forms setup with .NET Framework 4.0 & Crystal Reports as prerequisites. I get both of them as seperate .exe files when I deploy all the files on the client machine which does not have .NET Framework & Crystal Reports installed , I can see that first Crystal Reports installation begins , but it does not find .NET Framework installed and it stops!

     

      Can I change the sequence such that first .NET Framework is installed and then Crystal Reports......


    zeeshan jan
    Friday, January 27, 2012 8:37 AM
  • You can try with following way

    Go to following directory

    Drive letter:\Program Files\Microsoft SDKs\Windows\v7.0A\Bootstrapper\Packages\Crystal Reports for .NET Framework 4.0

    There you will find

    Product.xml

    Then find following tag

    <RelatedProducts>

    Under this tag you will find

    <DependsOnProduct Code="Microsoft.Net.Framework.2.0" />
    

    Now change it to

    <RelatedProducts>
        <DependsOnProduct Code=".NETFramework,Version=v4.0" />
    </RelatedProducts>
    

    Hope it will help u.

    Let me know about ur update.

     


    Hasibul Haque,MCC,MCPD hasibulhaque.com
    Friday, January 27, 2012 10:04 AM