locked
IIS slow website, microsoft web platform installer, wordpress site RRS feed

  • Question

  • User-1343526032 posted

    I'm not sure if this is the right place to put this so let me know if i should be looking elsewhere.  I have a 2008 r2 server running iis 7.5.  It is setup as dual core with 8GB of ram as a VM.  I set this server up a while ago and its been running fine up until now.  When i setup the server i ran the microsoft web platform installer to setup wordpress and make this server a wordpress server for a user group on our network.  They have recently made me aware that the site is taking a long time to load.  The server isn't using that much ram but i have noticed that there is one instance of php-cgi.exe 32 using 50% of the cpu. Its not constant, I would say it stays at 50% for about 6-8 seconds then drops to low utilization for a few seconds then will go back to 50%.

    I assume this is what the problem is but I don't know how to fix it.  Can anyone help?

    Thanks.

    Monday, August 29, 2016 3:36 PM

Answers

  • User-1343526032 posted

    Issue was permissions on the windows temp folder where too many session files resided causing slowness.  Fixed permissions for the temp directory and all is now well.

    Thanks

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, September 28, 2016 1:29 PM

All replies

  • User1278090636 posted

    Hi,

    Please try the following methods.

    1. Change the Max Instances settings

    • On the IIS server, launch IIS Manager
    • Select the website running php-cgi that is causing the high CPU usage
    • Under IIS, double click on FastCGI Settings
    • Click on the php-cgi.exe setting listed
    • This opens an option in the Actions menu on the right, called Edit…
    • Click Edit…
    • Change the Max Instances setting under General to 1

    2. Enable 32-Bit Applications

    Best Regards,

    Jean

    Tuesday, August 30, 2016 1:40 AM
  • User-1343526032 posted

    I did those and it is still slow.

    Tuesday, August 30, 2016 2:42 PM
  • User1278090636 posted

    Hi,

    Windows Cache Extension for PHP is a PHP accelerator that is used to increase the speed of PHP applications running on Windows and Windows Server. Once the Windows Cache Extension for PHP is enabled and loaded by the PHP engine, PHP applications can take advantage of the functionality without any code modifications.

    You can download the Windows Cache Extension for PHP via the following link.

    http://www.iis.net/downloads/microsoft/wincache-extension

    Best Regards,

    Jean

    Wednesday, August 31, 2016 1:49 AM
  • User-1343526032 posted

    I show I already have windows cache extension 1.3 for PHP 5.3 and PHP 5.4 installed.

    Wednesday, August 31, 2016 2:37 PM
  • User1278090636 posted

    Hi,

    Please use failed request tracing to trace requests, and you see the time used to process the request. Find out which event take long time.

    You can learn how to use the failed request tracing in the following link.

    http://www.iis.net/learn/troubleshoot/using-failed-request-tracing/troubleshooting-failed-requests-using-tracing-in-iis

    Best Regards,

    Jean

    Thursday, September 1, 2016 3:03 AM
  • User-1343526032 posted

    Is there another option or settings to check?  This is a production server.

    Friday, September 2, 2016 4:49 PM
  • User1278090636 posted

    Hi ventura,

    You can copy the site to a test server and have a check.

    The IIS Easy Migration Tool (IEMT) is a tool help migrate sites to another server.

    http://www.iis.net/downloads/community/2013/04/iis-easy-migration-tool-iemt 

    Best Regards,

    Jean

    Tuesday, September 6, 2016 8:15 AM
  • User-1343526032 posted

    When I run the gathering agent it states it only works on server 2003 and IIS 6.  Im using 2008 R2

    Tuesday, September 6, 2016 3:21 PM
  • User1278090636 posted

    Hi ventura,

    I'm not sure about what's the  gathering agent?

    Could you please explain what is it?

    Best Regards,

    Jean

    Wednesday, September 7, 2016 9:17 AM
  • User-1343526032 posted

    Its part of the IEMT.

    Wednesday, September 7, 2016 12:56 PM
  • User1278090636 posted

    Hi ventura,

    Sorry about that, please try use the WebDeploy tool to sync your IIS to another server.

    https://technet.microsoft.com/en-us/library/dd569005(v=ws.10).aspx

    Best Regards,

    Jean

    Thursday, September 8, 2016 7:33 AM
  • User-1343526032 posted

    OK, ive got the tracing installed.  When I add the failed request tracing rule what should I do?  All content, but what for a status code, or time taken

    Thursday, September 8, 2016 7:58 PM
  • User1278090636 posted

    Hi ventura,

    but what for a status code, or time taken

    Status code means which status of HTTP Response do you want to request. To troubleshoot slow performance, you can set this filed to 200-600. Then it will trace HTTP Response status from 200 to 600.

    Time taken means the time of a request is taken, if you set this value to 5, it will only trace requests that take longer 5s to finish loading.

    Best Regards,

    Jean

    Friday, September 9, 2016 6:40 AM
  • User-1343526032 posted

    Ok, thats going and i'm getting a bunch of xml files.  I looked through them and I can't tell what is going on.  Should I upload a few here?

    Friday, September 9, 2016 1:10 PM
  • User1278090636 posted

    Hi ventura,

    You can open these xml files in IE, then you can see the formatted log.

    And you can upload here too.

    Best Regards,

    Jean

    Monday, September 12, 2016 8:02 AM
  • User-1343526032 posted

    Here are the logs i collected for a few minutes.

    https://1drv.ms/f/s!Ao3_f7mdaGSrgrZB_dPLDqEHAd7QCQ

    Monday, September 12, 2016 12:57 PM
  • User1278090636 posted

    Hi ventura,

    I checked some of these logs, I find that it takes 10s - 20s to process some requests. Such as.

    Request: http://www.senate.iowa.gov:80/democrats/index.php
    NOTIFY_MODULE_COMPLETION 
    ModuleName:RewriteModule 
    Notification:BEGIN_REQUEST 
    fIsPostNotificationEvent:false 
    CompletionBytes:0 
    ErrorCode:The operation completed successfully.(0x0)
    26988 ms
    

    The RewriteModule takes long time to process these requests, please check your url rewrite settings.

    And some css, js, jpg files take 5s to process. Please try some methods to reduce the size of these files.

    Best Regards,

    Jean

    Tuesday, September 13, 2016 3:16 AM
  • User-1343526032 posted

    When i got to URL rewrite for that site in IIS there are no rules setup.  I don't recall setting url rewrite up

    Tuesday, September 13, 2016 1:19 PM
  • User-1343526032 posted

    Where are the settings I should be looking for?

    Thursday, September 15, 2016 12:44 PM
  • User-1343526032 posted

    Anyone out there have any clues?

    Friday, September 16, 2016 5:50 PM
  • User1618939190 posted

    You just need to use the new version of this software: IIS Easy Migration Tool 7 for IIS 7, 8, 10

    It migrates IIS 7/8/10 to 7/8/10.

    Monday, September 19, 2016 9:44 PM
  • User-1343526032 posted

    That's, not quite what I was asking.  I needed the easy migration tool so i could test on a non production server and then enable failed request tracing.  I got that going and it was determined by log that the URL rewrite was the cause of slowness and it was suggested to look at the settings for URL rewrite but my current dilemma is I don't have any settings set or I don't know where else to go to look for settings or configuration.  

    Tuesday, September 20, 2016 1:06 PM
  • User1278090636 posted

    Hi ventura,

    That's strange that the RewriteModule takes long time, but you don't have any rewrite rules.

    The following setting may help, please have a try.

    Enable 32-Bit Application Pool

    Best Regards,

    Jean

    Wednesday, September 21, 2016 9:18 AM
  • User-1343526032 posted

    Already enabled

    Wednesday, September 21, 2016 1:18 PM
  • User-1343526032 posted

    Any other ideas?

    Monday, September 26, 2016 12:56 PM
  • User-1343526032 posted

    Issue was permissions on the windows temp folder where too many session files resided causing slowness.  Fixed permissions for the temp directory and all is now well.

    Thanks

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, September 28, 2016 1:29 PM