locked
Auto numbering works when previewed but not in SharePoint RRS feed

  • Question

  • I believe I correctly set auto numbering for repeating sections (for web enable browser).

     myFields

         Field(Index_Count) ==> Default Value set to "1"

    Repeating Section

         Field(Qty) ==> Default Value set to "Index_Count"

                                 Rules set to Set_Item_Count "Set a field's value: Index_Count = Index_Count + 1"

     In preview, works great but when published to SharePoint - each section goes incrementally up by 2 ---- 1, 3, 5

    Any thoughts?

    ************************************************************************************************

    Follow up - When first opening up form in SharePoint and expanding repeating section it displays Qty - 1 - 2 - 2 - 2 - 2

    Submit and go back into form displays Qty - 1 - 2 - 4 - 6 - 8

    Weird!




    Tuesday, June 7, 2011 8:09 PM

All replies

  • Hi,

    Thanks to share your post.

    For the issue, If you are working on the Infopath Client then follow the below steps:

    1.       Add one expression box to repeating section.

    2.       Add "Position ()" function in the expression box properties.

    If you are working with Browser enabled form:
    count(preceding-sibling::my:<RepeatingGroupNodeName>) + 1.

    And also this reference for you:

    http://www.bizsupportonline.net/use-repeating-tables-infopath.htm.

    Hope it helps!

    Leo

    Friday, June 10, 2011 7:26 AM
  • Thanks so much for the simple formula!

    How can I get the the field published to SharePoint so the user knows how many sections are in the form without opening? I published with field as "count" but it does not display.

     

    Friday, June 10, 2011 6:52 PM