none
Agreement config and UNH, UNA questions BizTalk 2010 RRS feed

  • Question

  • We have a customer who is upgrading from BizTalk 2006 where they use Covast EDI to BizTalk 2010.

     

    Appart from having to to re-map to MS BizTalk version of edifact schemas I am having a bit of a problem with gettig UNA and UNH to be excactly like they have today. I hope somebody can help me out here.

     

    1. UNA segment. Currently their UNA segment looks like this: UNA:+,? But the one I am getting with BizTalk 2010 looks like this: UNA:+,?*  
      Any hint on how to remove * from the end of the UNA segment?
    2. UNH segment. Their UNH segment produced by Covast looks like this UNH+51+ORDERS:D:93A:UN:EFO20. I am not able to reproduce this. I only get:
      UNH+51+ORDERS:D:93A:UN
      So how can I add the last part ':EFO20' (i think it is UNH 2.5, or is it 2.4?) I have tried setting this in the Agreement under Transaction Set Settings and Local Host Settings, but it does not seem to have any effect. I also tried to populate UNH fields in the map I use to generate D 93A Orders, but this failed completely during processing. Any hints on how to work this out?
    3. Last question(for now). UNB 3.1 Receiver Identifier. The customer only use "custom" identifiers meaning UNB 3.2 is not set and UNB 3.1 is just some string they have created in agreement with the other party. But, the are currently using a string looking like this: 1234567890776:14
      The output should look like this: UNB+UNOC:2+98765432234+1234567890776:14 +110128:1135+65++ORDERS++0++0 but unfortunately it seems like BizTalk "escapes" the reserved symbol ':' so I am in fact getting : UNB+UNOC:2+98765432234+1234567890776?:14 +110128:1135+65++ORDERS++0++0
      Any way to make BizTalk ignore this and just print UNB 3.1 without "tampering" with the content?

     

    Friday, January 28, 2011 10:44 AM

Answers

  • I have to take your issues one at a time:

     

    I just deployed the "Edifact_ServiceSchemaExtension.xsd" schema with a few custom added UNB2.2 and UNB3.2 enumerations.

    I then restarted my BizTalk host instance and restarted my admin console. Now they appear under Agreement->Interchange Settings->Identifiers->Code qualifier (both 2.2 and 3.2). 

    The test was done on a BizTalk Server 2010 Developer Edition. Are you sure you have restarted both host instance(s) and admin console?

     

    I will look at mapping the UNH segment later.

    Morten la Cour

    • Marked as answer by Pål Carlsen Wednesday, February 2, 2011 8:03 AM
    Tuesday, February 1, 2011 4:20 PM
  • <ns0:EFACT_D93A_ORDERS xmlns:ns0="http://schemas.microsoft.com/BizTalk/EDI/EDIFACT/2006">
    <UNH>
        <UNH1>*</UNH1>
        <UNH2>
          <UNH2.1>ORDERS</UNH2.1>
          <UNH2.2>D</UNH2.2>
          <UNH2.3>93A</UNH2.3>
          <UNH2.4>UN</UNH2.4>
          <UNH2.5>EFO20</UNH2.5>
    </UNH2>
    </UNH>
    <ns0:BGM>
    <ns0:C002>
    <C00201>220</C00201>
    </ns0:C002>
    <BGM02>MS34586</BGM02>
    <BGM04>AE</BGM04>
    </ns0:BGM>
    <ns0:DTM>
    <ns0:C507>
    <C50701>137</C50701>
    <C50702>201102010833</C50702>
    <C50703>203</C50703>
    </ns0:C507>
    </ns0:DTM>
    <ns0:DTM>
    <ns0:C507>
    <C50701>4</C50701>
    <C50702>20110201</C50702>
    <C50703>102</C50703>
    </ns0:C507>
    </ns0:DTM>
    <ns0:DTM>
    <ns0:C507>
    <C50701>2</C50701>
    <C50702>20110201</C50702>
    <C50703>102</C50703>
    </ns0:C507>
    </ns0:DTM>
    <ns0:NADLoop1>
    <ns0:NAD>
    <NAD01>BY</NAD01>
    <ns0:C082>
    <C08201>10402</C08201>
    <C08203>91</C08203>
    </ns0:C082>
    <ns0:C080>
    <C08001>XX AS</C08001>
    </ns0:C080>
    <ns0:C059>
    <C05901>Y XXX</C05901>
    </ns0:C059>
    <NAD06>OSLO</NAD06>
    <NAD08>0614</NAD08>
    </ns0:NAD>
    <ns0:RFFLoop2>
    <ns0:RFF_2>
    <ns0:C506_2>
    <C50601>VA</C50601>
    <C50602>NO123456789MVA</C50602>
    </ns0:C506_2>
    </ns0:RFF_2>
    </ns0:RFFLoop2>
    <ns0:CTALoop1>
    <ns0:CTA>
    <CTA01>BD</CTA01>
    <ns0:C056>
    <C05601>4044</C05601>
    <C05602>XX XXX</C05602>
    </ns0:C056>
    </ns0:CTA>
    <ns0:COM>
    <ns0:C076>
    <C07601>23 14 34 53</C07601>
    <C07602>FX</C07602>
    </ns0:C076>
    </ns0:COM>
    </ns0:CTALoop1>
    </ns0:NADLoop1>
    <ns0:NADLoop1>
    <ns0:NAD>
    <NAD01>SU</NAD01>
    <ns0:C082>
    <C08201>942383</C08201>
    <C08203>92</C08203>
    </ns0:C082>
    <ns0:C080>
    <C08001>XXXXX XXXXAS</C08001>
    </ns0:C080>
    <ns0:C059>
    <C05901>XXXXXXXXXXX 177</C05901>
    </ns0:C059>
    <NAD06>OSLO</NAD06>
    <NAD08>0614</NAD08>
    </ns0:NAD>
    </ns0:NADLoop1>
    <ns0:LINLoop1>
    <ns0:LIN>
    <LIN01>1</LIN01>
    </ns0:LIN>
    <ns0:PIA>
    <PIA01>5</PIA01>
    <ns0:C212_2>
    <C21201>1243304</C21201>
    <C21202>EFO</C21202>
    </ns0:C212_2>
    </ns0:PIA>
    <ns0:IMD_2>
    <IMD01>F</IMD01>
    <ns0:C273_2>
    <C27304>KOBLINGBOKS KF 9045 5X4MM2</C27304>
    </ns0:C273_2>
    </ns0:IMD_2>
    <ns0:QTY_3>
    <ns0:C186_3>
    <C18601>21</C18601>
    <C18602>15</C18602>
    <C18603>PCE</C18603>
    </ns0:C186_3>
    </ns0:QTY_3>
    <ns0:DTM_13>
    <ns0:C507_13>
    <C50701>2</C50701>
    <C50702>20110203</C50702>
    <C50703>102</C50703>
    </ns0:C507_13>
    </ns0:DTM_13>
    <ns0:FTX_5>
    <FTX01>PUR</FTX01>
    <ns0:C108_5>
    <C10801>KF 9045</C10801>
    </ns0:C108_5>
    </ns0:FTX_5>
    <ns0:PACLoop2>
    <ns0:PAC_2>
    <ns0:C202_2>
    <C20201>ZZ</C20201>
    </ns0:C202_2>
    </ns0:PAC_2>
    <ns0:PCILoop2>
    <ns0:PCI_2>
    <ns0:C210_2>
    <C21001>MRK. 76.71904</C21001>
    </ns0:C210_2>
    </ns0:PCI_2>
    </ns0:PCILoop2>
    </ns0:PACLoop2>
    </ns0:LINLoop1>
    <ns0:LINLoop1>
    <ns0:LIN>
    <LIN01>2</LIN01>
    </ns0:LIN>
    <ns0:PIA>
    <PIA01>5</PIA01>
    <ns0:C212_2>
    <C21201>1243325</C21201>
    <C21202>EFO</C21202>
    </ns0:C212_2>
    </ns0:PIA>
    <ns0:IMD_2>
    <IMD01>F</IMD01>
    <ns0:C273_2>
    <C27304>KOBLINGBOKS KF 9255 5X16/25</C27304>
    </ns0:C273_2>
    </ns0:IMD_2>
    <ns0:QTY_3>
    <ns0:C186_3>
    <C18601>21</C18601>
    <C18602>4</C18602>
    <C18603>PCE</C18603>
    </ns0:C186_3>
    </ns0:QTY_3>
    <ns0:DTM_13>
    <ns0:C507_13>
    <C50701>2</C50701>
    <C50702>20110203</C50702>
    <C50703>102</C50703>
    </ns0:C507_13>
    </ns0:DTM_13>
    <ns0:FTX_5>
    <FTX01>PUR</FTX01>
    <ns0:C108_5>
    <C10801>KF 9255</C10801>
    </ns0:C108_5>
    </ns0:FTX_5>
    <ns0:PACLoop2>
    <ns0:PAC_2>
    <ns0:C202_2>
    <C20201>ZZ</C20201>
    </ns0:C202_2>
    </ns0:PAC_2>
    <ns0:PCILoop2>
    <ns0:PCI_2>
    <ns0:C210_2>
    <C21001>MRK. 76.71904</C21001>
    </ns0:C210_2>
    </ns0:PCI_2>
    </ns0:PCILoop2>
    </ns0:PACLoop2>
    </ns0:LINLoop1>
    <ns0:UNS>
    <UNS01>S</UNS01>
    </ns0:UNS>
    <ns0:CNT>
    <ns0:C270>
    <C27001>2</C27001>
    <C27002>2</C27002>
    </ns0:C270>
    </ns0:CNT>
    </ns0:EFACT_D93A_ORDERS>

    Still gets some invalid values in some segments, but you probably corrected this in your schema.

    Morten la Cour


    • Marked as answer by Pål Carlsen Thursday, February 3, 2011 7:59 AM
    Wednesday, February 2, 2011 12:18 PM

All replies

  • Ok, found the answer to some of my own questions.

     

    UNB: UNB 3.2 If what I need is a UNB 3.1 and 3.2 segment like this 1234567890776:14 I simply put 1234567890776 in UNB 3.1 and choose 14 from the dropdown list for UNB 3.2.


    This will work fine for the scenarios where my customer and there partners have agreed upon a UNB 3.2 value which is in this dropdown list. Unfortunately this is only true for about half of all the trading partner agreements. So my question is what do I do for the second half where BizTalks drop down list is not sufficient?

    Monday, January 31, 2011 9:19 AM
  • Last question first: 

     

    You can extend the allowed values in UNB2.2 and 3.2. See link:

     

    http://www.eggheadcafe.com/community/aspnet/70/10078426/bts2006creating-edifact-schema.aspx

     

    The link is for 2006 R2 but should work with 2010.

     

    1) UNA can be set pr. agreement. Under "Character sets and seperators" change UNA5 from "*" to " " (even though I can't see it in your example I assume it is a space char you want)

     

    2) There are two (at least, ofcourse message manipulation inside a pipeline component after edisend is always an option) options here: The first option is to map the UNH segment yourself, in your example it should look something like this:

    <UNH2>

      <UNH2.1>ORDERS</UNH2.1> 

      <UNH2.2>D</UNH2.2> 

      <UNH2.3>95A</UNH2.3> 

      <UNH2.4>UN</UNH2.4> 

      <UNH2.5>EFO20</UNH2.5> 

      </UNH2>

    If the following XML hits the edisend pipelineComponent, EFO20 will be inserted in UNH2.5

     

    The second option is a bit tricky and, in my opinion, not very smart. You need a schema deployed with a root node name: "EFACT_D93A_ORDERS_EFO20" instead of the standard schema "EFACT_D93A_ORDERS". You then need to the "EFACT_D93A_ORDERS_EFO20" structure before hitting the edisend pipeline component. This will result in the component inserting "EFO20" in UNH2.5.

    Morten la Cour

    Tuesday, February 1, 2011 9:09 AM
  • Hi. Thanks a lot for your ansver.

    I have been working with BizTalk for several years, but edifact has for some reason been the "last frontier".

     

    I have a couple of questions . I found the schema Edifact_ServiceSchemaExtensions.xsd and this does indeed seem to be just what I am after. But, after I added some values to this schema and deployed the assembly to biztalk I can, after a couple of hours, still not see my new values. Have I missed something, or have I simply edited the scema wrong?

    - <xs:element minOccurs="0" name="UNB2.2">
    - <xs:simpleType>
    - <xs:restriction base="EDIFACT_ID">
     <xs:enumeration value="SGG" /> 
     <xs:enumeration value="ZZ" /> 
     <xs:enumeration value="56" /> 
     <xs:enumeration value="ENH" /> 
     <xs:enumeration value="OD" /> 
     <xs:enumeration value="01" /> 
     <xs:enumeration value="NOLG" /> 
     </xs:restriction>
     </xs:simpleType>
    
    

    Regarding UNH. The first thing I tried was simply mapping these values in my map. But when I create an xml with UNH2 node similar to your example I get this error when trying to use ediSend pipeline

    The adapter failed to transmit message going to send port "SendPort_EDI" with URL "C:\Files\edifact\TP_edi_%MessageID%.txt". It will be retransmitted after the retry interval specified for this Send Port. Details:"Unable to read the stream produced by the pipeline. 
     Details: Error: 1 (Miscellaneous error)
    	71: Transaction Set or Group Control Number Mismatch ".

    Error: 1 (Miscellaneous error)
    	71: Transaction Set or Group Control Number Mismatch
    

    Is there any way to resolve this?

    The second option outlined does not seem very tempting. Does the edi send pipeline simply use the different parts of the root name to populate UNH2? This seems very strange to me.

     

    What excactly can I use "Local Host Settings" under "Transaction Set Settings" in the Partner Agreement? It looks to me like I should be able to populate UNH2.1, 2.2, 2.3 and 2.5 here, but my tries so far has been in vain.

     

    Thanks again for great input, hope someone can help me get further.

     

     

    Tuesday, February 1, 2011 12:34 PM
  • I have to take your issues one at a time:

     

    I just deployed the "Edifact_ServiceSchemaExtension.xsd" schema with a few custom added UNB2.2 and UNB3.2 enumerations.

    I then restarted my BizTalk host instance and restarted my admin console. Now they appear under Agreement->Interchange Settings->Identifiers->Code qualifier (both 2.2 and 3.2). 

    The test was done on a BizTalk Server 2010 Developer Edition. Are you sure you have restarted both host instance(s) and admin console?

     

    I will look at mapping the UNH segment later.

    Morten la Cour

    • Marked as answer by Pål Carlsen Wednesday, February 2, 2011 8:03 AM
    Tuesday, February 1, 2011 4:20 PM
  • UNH2.5 works for me, I am not sure what you are doing wrong? Can you show me the EDIXML you are sending through edisend?

    Yes the root element is used for defining UNH2 if not specified, it is very poorly documented, but there is a discussion about the topic here:

    http://social.msdn.microsoft.com/Forums/en/biztalkediandas2/thread/baf8c891-db11-4100-a9ab-dcc0dfa3f853

    Even though the issue here is the other way around (receiving EDIFACT).

    Local Host Settings can be used for giving incoming EDI messages a different namespace. Unfortunately this feature only works for one namespace (the default), additional namespaces only works if UNG segments are used (which they rarely are). I have discussed this with the product team, but since it is not a critical error I don't believe it will be fixed in 2010.

     

    Morten la Cour

    Tuesday, February 1, 2011 4:41 PM
  • I have to take your issues one at a time:

     

    I just deployed the "Edifact_ServiceSchemaExtension.xsd" schema with a few custom added UNB2.2 and UNB3.2 enumerations.

    I then restarted my BizTalk host instance and restarted my admin console. Now they appear under Agreement->Interchange Settings->Identifiers->Code qualifier (both 2.2 and 3.2). 

    The test was done on a BizTalk Server 2010 Developer Edition. Are you sure you have restarted both host instance(s) and admin console?

     

    I will look at mapping the UNH segment later.

    Morten la Cour


    Ah! I had simply not restarted my admin console! Ity is so seldom you do things in BizTalk which requires you to restart the admin console that I simply did not think about it.

     

    Restarted my admin console, and of course there they are, Works perfectly!

    Wednesday, February 2, 2011 8:02 AM
  •  <ns0:EFACT_D93A_ORDERS xmlns:ns0="http://schemas.microsoft.com/BizTalk/EDI/EDIFACT/2006">
    - <UNH>
    - <UNH2>
     <UNH2.5>EFO20</UNH2.5> 
     </UNH2>
     </UNH>
    - <ns0:BGM>
    - <ns0:C002>
     <C00201>220</C00201> 
     </ns0:C002>
     <BGM02>MS34586</BGM02> 
     <BGM04>AE</BGM04> 
     </ns0:BGM>
    - <ns0:DTM>
    - <ns0:C507>
     <C50701>137</C50701> 
     <C50702>201102010833</C50702> 
     <C50703>203</C50703> 
     </ns0:C507>
     </ns0:DTM>
    
    
    This is the begining of an edi xml. I created a send port with just passthru. The other sendport with edisend pipeline still gives me "Error: 1 (Miscellaneous error)
     71: Transaction Set or Group Control Number Mismatch&quot"

    I have of course tried to fill out every node in UNH2, not just UNH2.5, but the result is the same, when I populate some of the UNH nodes before the messages is submitted to the edisend pipeline I get this"Transaction Group Controll Number Mismatch" error. Is there any override in the admin console or some place else I should be setting? I have turned Data Validation of in the pipeline.
    Wednesday, February 2, 2011 8:56 AM
  • Can you please send the whole message

     

    Morten la Cour

    Wednesday, February 2, 2011 10:44 AM
  • Sure thing. here you go:

    <ns0:EFACT_D93A_ORDERS xmlns:ns0="http://schemas.microsoft.com/BizTalk/EDI/EDIFACT/2006">
    	<UNH>
    		<UNH2>
    			<UNH2.5>EFO20</UNH2.5>
    		</UNH2>
    	</UNH>
    	<ns0:BGM>
    		<ns0:C002>
    			<C00201>220</C00201>
    		</ns0:C002>
    		<BGM02>MS34586</BGM02>
    		<BGM04>AE</BGM04>
    	</ns0:BGM>
    	<ns0:DTM>
    		<ns0:C507>
    			<C50701>137</C50701>
    			<C50702>201102010833</C50702>
    			<C50703>203</C50703>
    		</ns0:C507>
    	</ns0:DTM>
    	<ns0:DTM>
    		<ns0:C507>
    			<C50701>4</C50701>
    			<C50702>20110201</C50702>
    			<C50703>102</C50703>
    		</ns0:C507>
    	</ns0:DTM>
    	<ns0:DTM>
    		<ns0:C507>
    			<C50701>2</C50701>
    			<C50702>20110201</C50702>
    			<C50703>102</C50703>
    		</ns0:C507>
    	</ns0:DTM>
    	<ns0:NADLoop1>
    		<ns0:NAD>
    			<NAD01>BY</NAD01>
    			<ns0:C082>
    				<C08201>10402</C08201>
    				<C08203>91</C08203>
    			</ns0:C082>
    			<ns0:C080>
    				<C08001>XX AS</C08001>
    			</ns0:C080>
    			<ns0:C059>
    				<C05901>Y XXX</C05901>
    			</ns0:C059>
    			<NAD06>OSLO</NAD06>
    			<NAD08>0614</NAD08>
    		</ns0:NAD>
    		<ns0:RFFLoop2>
    			<ns0:RFF_2>
    				<ns0:C506_2>
    					<C50601>VA</C50601>
    					<C50602>NO123456789MVA</C50602>
    				</ns0:C506_2>
    			</ns0:RFF_2>
    		</ns0:RFFLoop2>
    		<ns0:CTALoop1>
    			<ns0:CTA>
    				<CTA01>BD</CTA01>
    				<ns0:C056>
    					<C05601>4044</C05601>
    					<C05602>XX XXX</C05602>
    				</ns0:C056>
    			</ns0:CTA>
    			<ns0:COM>
    				<ns0:C076>
    					<C07601>23 14 34 53</C07601>
    					<C07602>FX</C07602>
    				</ns0:C076>
    			</ns0:COM>
    		</ns0:CTALoop1>
    	</ns0:NADLoop1>
    	<ns0:NADLoop1>
    		<ns0:NAD>
    			<NAD01>SU</NAD01>
    			<ns0:C082>
    				<C08201>942383</C08201>
    				<C08203>92</C08203>
    			</ns0:C082>
    			<ns0:C080>
    				<C08001>XXXXX XXXXAS</C08001>
    			</ns0:C080>
    			<ns0:C059>
    				<C05901>XXXXXXXXXXX 177</C05901>
    			</ns0:C059>
    			<NAD06>OSLO</NAD06>
    			<NAD08>0614</NAD08>
    		</ns0:NAD>
    	</ns0:NADLoop1>
    	<ns0:LINLoop1>
    		<ns0:LIN>
    			<LIN01>1</LIN01>
    		</ns0:LIN>
    		<ns0:PIA>
    			<PIA01>5</PIA01>
    			<ns0:C212_2>
    				<C21201>1243304</C21201>
    				<C21202>EFO</C21202>
    			</ns0:C212_2>
    		</ns0:PIA>
    		<ns0:IMD_2>
    			<IMD01>F</IMD01>
    			<ns0:C273_2>
    				<C27304>KOBLINGBOKS KF 9045 5X4MM2</C27304>
    			</ns0:C273_2>
    		</ns0:IMD_2>
    		<ns0:QTY_3>
    			<ns0:C186_3>
    				<C18601>21</C18601>
    				<C18602>15</C18602>
    				<C18603>PCE</C18603>
    			</ns0:C186_3>
    		</ns0:QTY_3>
    		<ns0:DTM_13>
    			<ns0:C507_13>
    				<C50701>2</C50701>
    				<C50702>20110203</C50702>
    				<C50703>102</C50703>
    			</ns0:C507_13>
    		</ns0:DTM_13>
    		<ns0:FTX_5>
    			<FTX01>PUR</FTX01>
    			<ns0:C108_5>
    				<C10801>KF 9045</C10801>
    			</ns0:C108_5>
    		</ns0:FTX_5>
    		<ns0:PACLoop2>
    			<ns0:PAC_2>
    				<ns0:C202_2>
    					<C20201>ZZ</C20201>
    				</ns0:C202_2>
    			</ns0:PAC_2>
    			<ns0:PCILoop2>
    				<ns0:PCI_2>
    					<ns0:C210_2>
    						<C21001>MRK. 76.71904</C21001>
    					</ns0:C210_2>
    				</ns0:PCI_2>
    			</ns0:PCILoop2>
    		</ns0:PACLoop2>
    	</ns0:LINLoop1>
    	<ns0:LINLoop1>
    		<ns0:LIN>
    			<LIN01>2</LIN01>
    		</ns0:LIN>
    		<ns0:PIA>
    			<PIA01>5</PIA01>
    			<ns0:C212_2>
    				<C21201>1243325</C21201>
    				<C21202>EFO</C21202>
    			</ns0:C212_2>
    		</ns0:PIA>
    		<ns0:IMD_2>
    			<IMD01>F</IMD01>
    			<ns0:C273_2>
    				<C27304>KOBLINGBOKS KF 9255 5X16/25</C27304>
    			</ns0:C273_2>
    		</ns0:IMD_2>
    		<ns0:QTY_3>
    			<ns0:C186_3>
    				<C18601>21</C18601>
    				<C18602>4</C18602>
    				<C18603>PCE</C18603>
    			</ns0:C186_3>
    		</ns0:QTY_3>
    		<ns0:DTM_13>
    			<ns0:C507_13>
    				<C50701>2</C50701>
    				<C50702>20110203</C50702>
    				<C50703>102</C50703>
    			</ns0:C507_13>
    		</ns0:DTM_13>
    		<ns0:FTX_5>
    			<FTX01>PUR</FTX01>
    			<ns0:C108_5>
    				<C10801>KF 9255</C10801>
    			</ns0:C108_5>
    		</ns0:FTX_5>
    		<ns0:PACLoop2>
    			<ns0:PAC_2>
    				<ns0:C202_2>
    					<C20201>ZZ</C20201>
    				</ns0:C202_2>
    			</ns0:PAC_2>
    			<ns0:PCILoop2>
    				<ns0:PCI_2>
    					<ns0:C210_2>
    						<C21001>MRK. 76.71904</C21001>
    					</ns0:C210_2>
    				</ns0:PCI_2>
    			</ns0:PCILoop2>
    		</ns0:PACLoop2>
    	</ns0:LINLoop1>
    	<ns0:UNS>
    		<UNS01>S</UNS01>
    	</ns0:UNS>
    	<ns0:CNT>
    		<ns0:C270>
    			<C27001>2</C27001>
    			<C27002>2</C27002>
    		</ns0:C270>
    	</ns0:CNT>
    </ns0:EFACT_D93A_ORDERS>

    Wednesday, February 2, 2011 11:49 AM
  • <ns0:EFACT_D93A_ORDERS xmlns:ns0="http://schemas.microsoft.com/BizTalk/EDI/EDIFACT/2006">
    <UNH>
        <UNH1>*</UNH1>
        <UNH2>
          <UNH2.1>ORDERS</UNH2.1>
          <UNH2.2>D</UNH2.2>
          <UNH2.3>93A</UNH2.3>
          <UNH2.4>UN</UNH2.4>
          <UNH2.5>EFO20</UNH2.5>
    </UNH2>
    </UNH>
    <ns0:BGM>
    <ns0:C002>
    <C00201>220</C00201>
    </ns0:C002>
    <BGM02>MS34586</BGM02>
    <BGM04>AE</BGM04>
    </ns0:BGM>
    <ns0:DTM>
    <ns0:C507>
    <C50701>137</C50701>
    <C50702>201102010833</C50702>
    <C50703>203</C50703>
    </ns0:C507>
    </ns0:DTM>
    <ns0:DTM>
    <ns0:C507>
    <C50701>4</C50701>
    <C50702>20110201</C50702>
    <C50703>102</C50703>
    </ns0:C507>
    </ns0:DTM>
    <ns0:DTM>
    <ns0:C507>
    <C50701>2</C50701>
    <C50702>20110201</C50702>
    <C50703>102</C50703>
    </ns0:C507>
    </ns0:DTM>
    <ns0:NADLoop1>
    <ns0:NAD>
    <NAD01>BY</NAD01>
    <ns0:C082>
    <C08201>10402</C08201>
    <C08203>91</C08203>
    </ns0:C082>
    <ns0:C080>
    <C08001>XX AS</C08001>
    </ns0:C080>
    <ns0:C059>
    <C05901>Y XXX</C05901>
    </ns0:C059>
    <NAD06>OSLO</NAD06>
    <NAD08>0614</NAD08>
    </ns0:NAD>
    <ns0:RFFLoop2>
    <ns0:RFF_2>
    <ns0:C506_2>
    <C50601>VA</C50601>
    <C50602>NO123456789MVA</C50602>
    </ns0:C506_2>
    </ns0:RFF_2>
    </ns0:RFFLoop2>
    <ns0:CTALoop1>
    <ns0:CTA>
    <CTA01>BD</CTA01>
    <ns0:C056>
    <C05601>4044</C05601>
    <C05602>XX XXX</C05602>
    </ns0:C056>
    </ns0:CTA>
    <ns0:COM>
    <ns0:C076>
    <C07601>23 14 34 53</C07601>
    <C07602>FX</C07602>
    </ns0:C076>
    </ns0:COM>
    </ns0:CTALoop1>
    </ns0:NADLoop1>
    <ns0:NADLoop1>
    <ns0:NAD>
    <NAD01>SU</NAD01>
    <ns0:C082>
    <C08201>942383</C08201>
    <C08203>92</C08203>
    </ns0:C082>
    <ns0:C080>
    <C08001>XXXXX XXXXAS</C08001>
    </ns0:C080>
    <ns0:C059>
    <C05901>XXXXXXXXXXX 177</C05901>
    </ns0:C059>
    <NAD06>OSLO</NAD06>
    <NAD08>0614</NAD08>
    </ns0:NAD>
    </ns0:NADLoop1>
    <ns0:LINLoop1>
    <ns0:LIN>
    <LIN01>1</LIN01>
    </ns0:LIN>
    <ns0:PIA>
    <PIA01>5</PIA01>
    <ns0:C212_2>
    <C21201>1243304</C21201>
    <C21202>EFO</C21202>
    </ns0:C212_2>
    </ns0:PIA>
    <ns0:IMD_2>
    <IMD01>F</IMD01>
    <ns0:C273_2>
    <C27304>KOBLINGBOKS KF 9045 5X4MM2</C27304>
    </ns0:C273_2>
    </ns0:IMD_2>
    <ns0:QTY_3>
    <ns0:C186_3>
    <C18601>21</C18601>
    <C18602>15</C18602>
    <C18603>PCE</C18603>
    </ns0:C186_3>
    </ns0:QTY_3>
    <ns0:DTM_13>
    <ns0:C507_13>
    <C50701>2</C50701>
    <C50702>20110203</C50702>
    <C50703>102</C50703>
    </ns0:C507_13>
    </ns0:DTM_13>
    <ns0:FTX_5>
    <FTX01>PUR</FTX01>
    <ns0:C108_5>
    <C10801>KF 9045</C10801>
    </ns0:C108_5>
    </ns0:FTX_5>
    <ns0:PACLoop2>
    <ns0:PAC_2>
    <ns0:C202_2>
    <C20201>ZZ</C20201>
    </ns0:C202_2>
    </ns0:PAC_2>
    <ns0:PCILoop2>
    <ns0:PCI_2>
    <ns0:C210_2>
    <C21001>MRK. 76.71904</C21001>
    </ns0:C210_2>
    </ns0:PCI_2>
    </ns0:PCILoop2>
    </ns0:PACLoop2>
    </ns0:LINLoop1>
    <ns0:LINLoop1>
    <ns0:LIN>
    <LIN01>2</LIN01>
    </ns0:LIN>
    <ns0:PIA>
    <PIA01>5</PIA01>
    <ns0:C212_2>
    <C21201>1243325</C21201>
    <C21202>EFO</C21202>
    </ns0:C212_2>
    </ns0:PIA>
    <ns0:IMD_2>
    <IMD01>F</IMD01>
    <ns0:C273_2>
    <C27304>KOBLINGBOKS KF 9255 5X16/25</C27304>
    </ns0:C273_2>
    </ns0:IMD_2>
    <ns0:QTY_3>
    <ns0:C186_3>
    <C18601>21</C18601>
    <C18602>4</C18602>
    <C18603>PCE</C18603>
    </ns0:C186_3>
    </ns0:QTY_3>
    <ns0:DTM_13>
    <ns0:C507_13>
    <C50701>2</C50701>
    <C50702>20110203</C50702>
    <C50703>102</C50703>
    </ns0:C507_13>
    </ns0:DTM_13>
    <ns0:FTX_5>
    <FTX01>PUR</FTX01>
    <ns0:C108_5>
    <C10801>KF 9255</C10801>
    </ns0:C108_5>
    </ns0:FTX_5>
    <ns0:PACLoop2>
    <ns0:PAC_2>
    <ns0:C202_2>
    <C20201>ZZ</C20201>
    </ns0:C202_2>
    </ns0:PAC_2>
    <ns0:PCILoop2>
    <ns0:PCI_2>
    <ns0:C210_2>
    <C21001>MRK. 76.71904</C21001>
    </ns0:C210_2>
    </ns0:PCI_2>
    </ns0:PCILoop2>
    </ns0:PACLoop2>
    </ns0:LINLoop1>
    <ns0:UNS>
    <UNS01>S</UNS01>
    </ns0:UNS>
    <ns0:CNT>
    <ns0:C270>
    <C27001>2</C27001>
    <C27002>2</C27002>
    </ns0:C270>
    </ns0:CNT>
    </ns0:EFACT_D93A_ORDERS>

    Still gets some invalid values in some segments, but you probably corrected this in your schema.

    Morten la Cour


    • Marked as answer by Pål Carlsen Thursday, February 3, 2011 7:59 AM
    Wednesday, February 2, 2011 12:18 PM
  • Brilliant!

    Apparently you have to fill out UNH1 with <UNH1>*</UNH1> if you intend to populate UNH2 elements manually. Thank you so much for you help, it has been really helpfull.

     

    And, regarding invalid values in segments in my sample message. I am perfectly aware of this. I have to turn of all EDI validation on both send and receive because the messages I am receiving contains a lot of invalid values. Some partners insists that their messages have to be declared as UNOA even if they send and receive upper and lower case letters plus scandinavian letters like ØÆÅ...

     

    I will probably have to make a pipeline that replaces UNOC with UNOA/UNOB after edi assembler has been applied in order to succesullly comply to this demand.

    Thursday, February 3, 2011 8:12 AM
  • HI ,

    i am facing the same problem as i added new custom fields to the schema and deployed it, restarted host instances and admin console. still not able to see the UNB 2.2 and UNB 3.1 fields. kindly assist and its bit emergency for me as i need to move the solution to production after testing.please let me know if more information required.


    Regards, Bala.

    Wednesday, August 20, 2014 10:29 PM
  • What do you mean that you're "not able to see the UNB 2.2 and UNB 3.1 fields"? 

    The UNA and UNB segment is not defined in the EDIFACT Schemas but rather in the Agreements.

    Morten la Cour

    Thursday, August 21, 2014 6:33 AM
  • HI Cour,

    Thanks for the reply. To elaborate on my issue. i had added the schema(Edifact_ServiceSchemaExtension.xsd) with my custom values for UNB2.2 and UNB3.1 as ZZ, in a new project ,built and deployed the solution. restarted the host-instances and administration console. 

    when i go into the agreements of the party i cannot find the custom value ZZ in the dropdown list for UNB2.2 or UNB3.1 .

    the above scenario is working fine for the solution which is already in the production deployed long back.as i forgot to say i am trying this in my test server as part of integration testing.

    please suggest as anywhere am i going wrong in the process.please let me know if more information required.


    Regards, Bala.

    Thursday, August 21, 2014 7:28 AM
  • Are you sure you don't mean UNB2.2 and UNB3.2?

    Morten la Cour

    Thursday, August 21, 2014 10:43 AM
  • Hi 

    To remove the UNA segment uncheck the Apply UNA Segment.

    Goto Parties--> Agreement --> Second Tab under Click on envelopes.


    Regards, Aboorva Raja R Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, February 19, 2016 6:25 PM