none
Remote Tools PB CE6.0 launched from VS2005 are not working RRS feed

  • Question

  • I've installed VS2005 and PB CE 6.0 SP1.

    Remote Tools from "START->Programs->Visual Studio 2005->Visual Studio Remote Tools" are working fine, but some tools are not available there (Remote Kernel Tracker for example...).
    So I try to use Remote Tools lauched from VS2005 (Target->Remote Tools) but there is not my CE6.0 device in the list of devices to select. I've installed the SDK generated with my OSDesign, but the device is not present in the list.
    I also tried to add manually a new device and select Active Sync as Transport and Startup Server, but it is still not working.

    Is there anyone that was able to use Remote Tools from VS2005 with CE6.0? How to do it?

    • Edited by CEdev Thursday, December 2, 2010 11:06 AM
    Wednesday, December 1, 2010 5:16 PM

Answers

All replies

  • So *none* of the remote tools launched from inside VS2005 work?  Or only certain ones don't work?  I think you have to have built the OS a certain way to use the Kernel Tracker, don't you?  What solution type is loaded into your VS2005 IDE at the time when you do this?

    Paul T.

    Wednesday, December 1, 2010 5:30 PM
  • Hi Paul,

    yes, none of remote tools launched from inside VS2005 (installed with PB CE6.0) is working for me.
    I tried with my OSDesign solution open, but also with no solution or with other application's solutions, the result is always the same: there isn't my device in the list of devices in the Platform Manager Configuration inside each remote tool.

    In Platform Manager Configuration I have just "Windows CE Default Platform", nothing else!

    Instead with standard remote tools installed with VS2005 (launched outside VS2005) all is working fine, I can select all the devices whose SDK is installed on my PC and I can connect with them successfully.

    I don't understand about this difference...

    Thursday, December 2, 2010 11:02 AM
  • I found a link that solved my problem:

    http://groups.google.com/group/microsoft.public.windowsce.platbuilder/browse_thread/thread/a7af4d568659bc3b/8d117876157dc7e5?lnk=gst&q=activesync+remote+6.0#8d117876157dc7e5

    I created a copy of folder "C:\Program Files\Common Files\Microsoft Shared\Windows CE
    Tools\Platman\target\wce600\armV4i" and renamed as "C:\Program Files\Common Files\Microsoft Shared\Windows CE
    Tools\Platman\target\wce600\armV4". That's all!

    After that I'm able to connect to my device via ActiveSync from remote tools inside VS2005.

    • Marked as answer by CEdev Thursday, December 2, 2010 11:52 AM
    Thursday, December 2, 2010 11:51 AM
  • Does your device report a processor type of ARMv4, then?

    Paul T.

    Monday, December 6, 2010 5:03 PM
  • Does your device report a processor type of ARMv4, then?

    Paul T.

    My processor is Freescale iMX51, I always used ARMV4I.
    Thursday, December 9, 2010 2:28 PM