none
Visual Studio runs too slow and problems with editing solutions

    Question

  • I wanted to make a website based on ASP.NET MVC and C#. As is usually Visual Studio runs from 2 to 5 minutes so I could in the same time make and eat breakfast and brush my teeth. Next, loading solution also tooks as much again. The worst began when I began edit view file .cshtml. Then VS crashes. Always when I try edit .cshtml files VS crashes. As if this is not enough VS no longer recognizes libraries on my project which I added yesterday. Anyone know what's up with the odd behavior of the compiler?
    Sunday, April 24, 2016 1:37 PM

Answers

  • Hi Hubot.NET,

    I would suggest to test the /safemode parameter first to see if the startup time is different. Also /resetsettings might be worth a try.

    I would expect a better startup time of Visual Studio on a Toshiba Satellite C660D so it is quite likely that something is wrong on your system.

    With kind regards,

    Konrad

    Sunday, April 24, 2016 7:02 PM
    Moderator
  • Thanks for Konrad Neitzel's help.

    Hi Hubot.NET,

    I agree with Konrad Neitzel's suggestion. Please try above steps 4 to step 6, which can help us troubleshoot this problem.

    If that steps doesn't work, please try clear Visual Studio caches under following paths.

    C:\Users\v-weiwca\AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache

    C:\Users\v-weiwca\AppData\Local\Temp

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, April 26, 2016 3:27 AM
    Moderator

All replies

  • Hi,

    could you give more details?

    - What kind of computer do you run on?

    - Which OS / Visual Studio version do you use?

    - Did you install any addons to Visual Studio? (or products that integrate themself into Visual Studio)?

    - Did you try to reset the settings (/ResetSettings parameter when starting devenv.exe)

    - Did you try to start in safe mode (/SafeMode parameter when starting devenv.exe)

    - Did you try to repair the Visual Studio Installation and maybe also .Net?

    Visual studio takes some time to start, but if you really measured that time, then it simply is to long. I do not have such startup times when I start Visual Studio 2015 on my old DELL Latitude D830 (4GB RAM, SSD but on older SATA port with ReSharper Ultimate installed including all modules.)

    With kind regards,

    Konrad Neitzel

    Sunday, April 24, 2016 5:57 PM
    Moderator
  • 1. Toshiba Satellite C660D

    2. Windows 10 Pro / Visual Studio 2015 Community

    3. Yes, I've installed VS including all modules

    4. No, I didn't

    5. No, I didn't

    6. No, I didn't

    Sunday, April 24, 2016 6:46 PM
  • Hi Hubot.NET,

    I would suggest to test the /safemode parameter first to see if the startup time is different. Also /resetsettings might be worth a try.

    I would expect a better startup time of Visual Studio on a Toshiba Satellite C660D so it is quite likely that something is wrong on your system.

    With kind regards,

    Konrad

    Sunday, April 24, 2016 7:02 PM
    Moderator
  • Thanks for Konrad Neitzel's help.

    Hi Hubot.NET,

    I agree with Konrad Neitzel's suggestion. Please try above steps 4 to step 6, which can help us troubleshoot this problem.

    If that steps doesn't work, please try clear Visual Studio caches under following paths.

    C:\Users\v-weiwca\AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache

    C:\Users\v-weiwca\AppData\Local\Temp

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, April 26, 2016 3:27 AM
    Moderator