none
Unable to install on Windows 10 RRS feed

  • Question

  • I have been trying to install SyncToy on a new to me machine that is running Windows 10 64-bit Build 1809. It just cannot seem to get beyond looking for the .NET 2.0 package. I have installed both installation files twice, the second time manually extracting the 3 compressed installation files, and run a repair install on it, but to no avail.

    Has some W10 update broken this?

    Also, is there any truth in the story that Microsoft are working on updated versions of this set of programs, including Synctoy?

    Meanwhile, what is the closest substitute for SyncToy that does work?


    • Edited by Billaboard Tuesday, June 11, 2019 5:09 PM
    Tuesday, June 11, 2019 5:07 PM

All replies

  • Having wasted ages on this, I discovered that when the installation asked for the Net Framework v. 2.0 to be installed, you have to go to the option to download the full package, then go to the bottom of the list of versions that appears and install V 3.5 sp1. Following the route provided by the SyncToy installation wrongly takes you to v. 4.8, which says "recommended".

    Why on earth can Microsoft produce clear instructions for something like this? Or, better still, incorporate all the necessary components into the installation files?

    I want to keep using SyncToy, as over the years I have recommended it to friends, and most of them are using it for backups. They understand what it does and how to use it.


    • Edited by Billaboard Sunday, June 16, 2019 2:30 PM
    Sunday, June 16, 2019 2:29 PM
  • To install SyncToy 2.1 on Win 10:

    FIRST, YOU MUST

       use control panel | programs and features | Turn Windows Features On or Off

       and CHECK the box for "MS .Net 3.5.1" so that W10 will install that.

    THEN

       go ahead and run the SyncToy installer.

    Unlike W7, W10 didn't bother to install that older .Net runtime.  And no, the more modern 4.5 [.6 or .7 or .8] won't do it even tho they supposedly do supersede 3.5

    Friday, June 21, 2019 8:34 PM
  • Thanks, that's good to know and better thn my method of searching for the correct download.

    However, I still think the download of Synctoy should lead you to the correct .NET download or installation method.

    Saturday, June 22, 2019 3:46 PM
  • Thanks! I was struggling with this too until I tried your solution! All good now :)
    Thursday, October 17, 2019 6:47 AM