locked
Unable to debug any windows metro application using Visual Studio 2011

    Question

  • I'm using a fresh Windows 8 install on Virtual Box with 2GB Ram on a core I5 Laptop. My screen solution is 1024x768. I try multiple times to debug a windows metro application using Visual Studio 11, for my project or other WinRT examples on MSDN, but I can not debug anyone of those. The application was deployed, started and then exist without reason or exception. After a long waiting time, VS11 return the error below:

    Unable to activate Windows Metro style application

    I've tried upgrading from Windows 7 and failed in getting a developer certificate for Windows Metro app. Then I tried to have a fresh Windows 8 install on my laptop, and I failed to install ASP.NET MVC 3 template on Visual Studio 2010. And now, I face the above problem.

    Hope that some one can help me to solve the problem above! 

     
    Sunday, March 18, 2012 9:10 AM

All replies

  • Hello,

    So based on your description, you are getting the above error message in a Virtual Box and a non-Virtual Box scenario?

    Is this happening in a local, remote, or simulator debug scenario? (Right click on the project node in solution explorer, Debug property page/tab, Target device (local, simulator, remote)   Also what is the configuration on the laptop where you get the above error e.g.

    Windows 8 Consumer Preview

    VS 11 Beta

    Does this happen with a new metro application? i.e. File | New Project | Visual C# | Blank Application?

    Not a workaround but if you launch the metro application via Ctrl + F5, then go to debug | attach to process, does the debugger attach to the metro application successfully? I am just trying to get more info on your situation.

    much appreciated,

    mike

    Monday, March 19, 2012 10:20 PM
    Moderator