none
SD card as Mass Storage via USB RRS feed

  • Question

  • Hi,

    I want to expose SD card in device(working with WEC2013 BSP) in PC, using USB cable. The card gets unmounted from the device and  in PC-Device Manager it is shown as USB Mass Storage Device, but in explorer if I try to access it PC gets hanged and doesn't come back unless i remove the connection. I've a confusion about that whether the problem would be in USBFn driver or SDHC driver. What could be the reason for this failure? Thanks

    Tuesday, August 12, 2014 11:34 AM

All replies

  • It is USB.  Your system doesn't even know that there is an SD card involved, it sees a USB Mass Storage device.

    Bruce Eitman (eMVP) Senior Engineer Bruce.Eitman AT Eurotech DOT com My BLOG http://geekswithblogs.net/bruceeitman Eurotech Inc. www.Eurotech.com

    Tuesday, August 12, 2014 12:11 PM
    Moderator
  • Thanks for your reply sir. But, the next thing I tried was to expose NAND as Mass Storage, it worked. I then tried to find where the problem occurs by enabling debug messages(tried Checked build), which resulted in "Device descriptor failed" message in PC. 

    P.S. I also have a WinCE 6.0 BSP which works fine exposing SD card in PC. Is there any major change between USBFn driver of WinCE 6 and WEC2013? Thanks again


    Tuesday, August 12, 2014 1:52 PM
  • If Device descriptor fails then you cant see USB Mass Storage Device in PC. Please verify couple of times what exactly is happening. If you are able to see USB Mass storage Device in PC then when you are access , is it hangs? or Is USB Enumeration successful?

    As per my WEC2013 experience, There are minor changes involved related to Power Management hander in USBFn driver.

    Suggestions:

    1. Compare between reference BSP for WCE6 and WEC2013 and get some information about what all are changes implemented in SDHC and USB Drivers.

    2. Track through Debug messages with debug build

    3. Check any exception, if so enable KITL then reproduce the case and track

    Wednesday, August 13, 2014 4:11 AM