locked
2008 compatibility with 1.5? RRS feed

  • Question

  • Hello,
    We have a robot that came with a whole suite of specialized software (closed source) all built for MSRS 1.5. This robot is very complicated and all communication with the base is proprietary so there is no opportunity to write a new interface in MRDS 2008.

    Can a MRDS 2008 service talk to a service from 1.5?

    What are our options in terms of moving forward? Are we stuck with 1.5?

    Thanks for your help.

    Paul
    Thursday, December 3, 2009 7:15 PM

Answers

  • I also haven't tried 1.5 to 2008 compatibility, but I know that 2008 to 2008 R2 *kind of* works.  So you might expect the same performance between 1.5 and 2008. 

    We have found that if you have 2 DssHost nodes, each on a different computer, one is version 2008, and one is 2008 R2, most services will be able to talk across the connection.  However, some services won't be able to.  I forget the specifics, but I am pretty sure our webcam service didn't work.

    -Ben
    www.coroware.com
    Tuesday, January 19, 2010 9:16 PM

All replies

  • I am curious, which robot?


    www.coroware.com
    Saturday, December 5, 2009 5:29 AM
  • It's a Robosoft robot. Is anyone going to answer this?

    Paul
    Monday, January 18, 2010 4:48 AM
  • I believe that Robosoft has a version of their software for RDS 2008. You should talk to them.

    In theory a 1.5 DSS node can talk to a 2008 node, but I have never tried it. We run multiple nodes all the time and talk from one to the other, but there might be some issues across different versions.

    Trevor
    Monday, January 18, 2010 7:21 AM
  • I also haven't tried 1.5 to 2008 compatibility, but I know that 2008 to 2008 R2 *kind of* works.  So you might expect the same performance between 1.5 and 2008. 

    We have found that if you have 2 DssHost nodes, each on a different computer, one is version 2008, and one is 2008 R2, most services will be able to talk across the connection.  However, some services won't be able to.  I forget the specifics, but I am pretty sure our webcam service didn't work.

    -Ben
    www.coroware.com
    Tuesday, January 19, 2010 9:16 PM