locked
Could not load file or assembly Oracle.DataAccess RRS feed

  • Question

  • User-1113162323 posted

    Hi,

    I added a reference (a component .dll) in my website project and tried to use the component. This component has a reference to Oracle.DataAccess (Version=10.1.0.400). But whenever I tried to access a function in the component that accessing the database. Runtime error occurrs.

    Error:

    Could not load file or assembly 'Oracle.DataAccess, Version=10.1.0.400, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    I have added the Oracle.DataAccess reference in my website project but with different version (Version=10.2.0.100).

    Is the version significant? What should I do to remove this error? Btw, I'm using OracleXE and I think the component used different version.

    Hope someone will guide me to fixing this error. Cheers.

    Tuesday, December 23, 2008 8:50 AM

All replies

  • User-1952482173 posted

    Check Oracle.DataAccess version in folder WINDOWS\assembly\. If the version is not 10.1.0.400, you need to add this version. Or, you have to change the reference in your component component.dll project to refer to version 10.2.0.100 if you have the right to do it.

    Tuesday, December 23, 2008 10:57 AM
  • User-1113162323 posted

    Thanks for your reply.

    I've checked in Windows\assembly and there are no Oracle.DataAccess. But its in oraclexe\app\oracle\product\10.2.0\server\BIN. I'll try to download the 10.1.0.400 in the oracle website and try adding it.

    I'm not sure if im downloading the right file. I found it here: http://www.oracle.com/technology/software/tech/windows/odpnet/index.html

    And downloaded the "Oracle 10g ODAC 10.1.0.4.0" is this the correct file?

     

    Wednesday, December 24, 2008 10:40 PM
  • User-1113162323 posted

    Hi,

    I downloaded the ODAC and installed it, Its now connected to the oracle successfully. Thanks!

    Friday, December 26, 2008 10:01 AM
  • User-1113162323 posted

    After restarting my PC, now it does not connect to oracle. When it attempts to connect to oracle, error occurred. (ORA-24315 Illegal Attribute Type).

    I've included the new Oracle.DataAccess in my Project reference.

    What should I do to make it work? I've search on the net and there are no results.

    Wednesday, December 31, 2008 4:23 AM
  • User-2118667448 posted

     Wow! Thanks for the tip on checking WINDOWS\assembly

     I found a conflict in there on one of my servers. Removed the unneeded Oracle entries and that resolved our ODP.NET issue.


    Thanks again!

    Tuesday, March 24, 2009 6:41 PM
  • User-1952710888 posted

    Could not load file or assembly Oracle.DataAccess

    Wednesday, January 4, 2017 7:46 AM