none
cannot RDP to the VM, RRS feed

  • Question

  • New to Azure , I stopped the VM that was running from the dashboard (ARM), I had selected A3 VM size when deployed in West US region , changed the VM size to DS premium. 
     Now I cannot RDP to the VM, tried the troubleshooting on the portal but still no go.
     I have tried so far: 
     Shutdown/Restart
     troubleshooter/Redeploy option on the Portal.
     resize again

     Not sure what else to try, can anyone give pointers? Also, can I move this VM to East US? 
    Tuesday, December 27, 2016 9:43 AM

Answers

All replies

  • Hello,

     

    Thank you for contacting Microsoft forums. We are pleased to answer your query.

    Are you getting any specific error when you are trying to RDP to VM?

    You may also refer this document which describes Troubleshoot Remote Desktop connections to an Azure virtual machine:https://docs.microsoft.com/en-us/azure/virtual-machines/virtual-machines-windows-troubleshoot-rdp-connection?toc=%2fazure%2fvirtual-machines%2fwindows%2ftoc.json

    I hope that the reply will assist you in getting your query addressed. In case you require further assistance, please do reply to the thread as we are always available to your queries.

    Regards,

    Monika

    _________________________________________________________________________If this post was helpful to you, please up vote it and/or mark it as an answer so others can more easily find it in the future

    Tuesday, December 27, 2016 2:46 PM
  • Hi,

    Addition to Monika reply;

    Yes, you can move/migrate the VM to different region; Refer to the below mentioned link.

    https://docs.microsoft.com/en-us/azure/site-recovery/site-recovery-migrate-azure-to-azure

    Migrating Azure services to new regions

    For more information, related Remote Desktop connections issues; Click here

    Regards,
    Sumanth BM

    • Marked as answer by proudoo.rat Wednesday, December 28, 2016 9:25 AM
    Tuesday, December 27, 2016 6:07 PM
  • Thanks SumanthBM
    Wednesday, December 28, 2016 9:25 AM
  • well it looks like you deleted and recreated the VM as opposed to migrate. I say this as you swapped from A series (standard) to D Series (premium). 

    That tells me you deleted and recreated. So I am going to skip the restore mentioned by the other poster. 

    It is good practice to put the VM into an Availability set as its harder to do later. You may also wish to add a load balancer as well. 

    If you do the latter you need to setup a NAT rule for RDP. You will also need to ensure that Network Security Groups NSGs are allowing port 3389 too. 

    NSG's can be applied at VM and network layers. If the traffic in ingress you need to do network NSG's then machine NSG's. If you are doing egress you need to do it the opposite way. Machine then Network. 



    ronny

    Wednesday, December 28, 2016 9:37 AM
  • One other thing to be aware of is allowing RDP to ALL of your machines is poor security practice. There are a few other options that negate the need for doing that. 

    1) setup an RD Gateway server (assuming your using windows, will need DC's and CAs as well)

    2) setup VPN access either P2S or S2S. The former is a single user solution that letter multiple users or corporate site use. 

    Do NOT setup public IP's on all of your servers. 


    ronny

    Wednesday, December 28, 2016 9:40 AM