none
connecting via ssh client RRS feed

  • Question

  •  ssh admin@Kafkaepam-ssh.azurehdinsight.net

    i'm getting access denied error while connecting to the HDInsight cluster

    Tuesday, August 20, 2019 2:46 PM

Answers

  • Hi manjerekar rao,

    You cannot ssh using admin@chepra-ssh.azurehdinsight.net.

    Reason: admin is used to connect to cluster using Cluster login.

    Note: Cluster login username: admin => Cluster login credentials can be used to submit jobs, monitor resource usage and log in to cluster dashboard.

    For more details refer “Manage Apache Hadoop Cluster in HDInsight by using Azure Portal”.

    Connect to cluster using Secure Shell (SSH): 

    Secure Shell (SSH) username is used to login via ssh client.

    You can securely connect to the below endpoints in the HDInsight cluster with an SSH client. 

    Step1: Go to created HDInsight Cluster => Under settings => SSH + Cluster login => Select Hostname=> Click on copy “ssh sshuser@chepra-ssh.azurehdinsight.net”.

    Step2: Open putty => Enter Hostname and port number

    Hostname: sshuser@chepra-ssh.azurehdinsight.net

    Port: 22

    Note: If you are copying Hostname from Azure Portal, try to remove ssh and paste in putty.

    It should be sshuser@chepra-ssh.azurehdinsight.net and not “ssh sshuser@chepra-ssh.azurehdinsight.net”.

    Step3: Enter password to login: **********

    Successfully connected to HDInsight cluster using putty.

    For more details, refer “Connect to HDInsight using SSH”.

    Hope this helps.

    Wednesday, August 21, 2019 4:56 AM
    Moderator
  • Hi manjerekar rao,

    Just checking in to see if the above answer helped. If this answers your query, do click “Mark as Answer” and Up-Vote for the same. And, if you have any further query do let us know.

    Tuesday, August 27, 2019 7:15 AM
    Moderator
  • thanks Pradeep.

    I realized that I was using admin as the username for the ssh client too. since I used admin as the username for the ssh client, it created a file under the path C:\Users\<abc>\.ssh\known-hosts.

    this file has the encrypted fingerprint information of the user. so any logins there after results in a access denied or permission denied error, coz, the first login resulted in wrong username.

    so, what I did was to delete the above file from the path and re-connected to the ssh client with a valid username.

    this resolved my issue. so it's always good to provide a username for the ssh client instead of the default sshuser.

    thanks for the detailed explanation, Pradeep.


    Manjurekar Rao

    Tuesday, August 27, 2019 8:11 AM

All replies

  • Hi manjerekar rao,

    You cannot ssh using admin@chepra-ssh.azurehdinsight.net.

    Reason: admin is used to connect to cluster using Cluster login.

    Note: Cluster login username: admin => Cluster login credentials can be used to submit jobs, monitor resource usage and log in to cluster dashboard.

    For more details refer “Manage Apache Hadoop Cluster in HDInsight by using Azure Portal”.

    Connect to cluster using Secure Shell (SSH): 

    Secure Shell (SSH) username is used to login via ssh client.

    You can securely connect to the below endpoints in the HDInsight cluster with an SSH client. 

    Step1: Go to created HDInsight Cluster => Under settings => SSH + Cluster login => Select Hostname=> Click on copy “ssh sshuser@chepra-ssh.azurehdinsight.net”.

    Step2: Open putty => Enter Hostname and port number

    Hostname: sshuser@chepra-ssh.azurehdinsight.net

    Port: 22

    Note: If you are copying Hostname from Azure Portal, try to remove ssh and paste in putty.

    It should be sshuser@chepra-ssh.azurehdinsight.net and not “ssh sshuser@chepra-ssh.azurehdinsight.net”.

    Step3: Enter password to login: **********

    Successfully connected to HDInsight cluster using putty.

    For more details, refer “Connect to HDInsight using SSH”.

    Hope this helps.

    Wednesday, August 21, 2019 4:56 AM
    Moderator
  • Hi manjerekar rao,

    Just checking in to see if the above answer helped. If this answers your query, do click “Mark as Answer” and Up-Vote for the same. And, if you have any further query do let us know.

    Tuesday, August 27, 2019 7:15 AM
    Moderator
  • thanks Pradeep.

    I realized that I was using admin as the username for the ssh client too. since I used admin as the username for the ssh client, it created a file under the path C:\Users\<abc>\.ssh\known-hosts.

    this file has the encrypted fingerprint information of the user. so any logins there after results in a access denied or permission denied error, coz, the first login resulted in wrong username.

    so, what I did was to delete the above file from the path and re-connected to the ssh client with a valid username.

    this resolved my issue. so it's always good to provide a username for the ssh client instead of the default sshuser.

    thanks for the detailed explanation, Pradeep.


    Manjurekar Rao

    Tuesday, August 27, 2019 8:11 AM
  • Hi manjerekar rao,

    Glad to know that your issue has resolved.

    Tuesday, August 27, 2019 8:26 AM
    Moderator