none
PerformOperation returned 1603 (translates to HRESULT = 0x80070643) RRS feed

  • Question

  • .NET Framework 4.0 Full package installation failed with error code: (0x80070643)

    I have a problem to install Microsoft .NET Framework 4 under Windows 7-x64.

    With the Standalone installer i get the same error as  over the Windows update.

    YiChun Chen (CS&S) you describe that you need this cab file to analyse the error, i have send this.

    I hope you have a solution for me.

    Thursday, August 5, 2010 5:16 PM

Answers

  • Hi Fruell,

    Thank you for your email and log files.

    For error code "0x80070643", it's a common message that means "fatal error during installation".

    I've checked your log files and found the following critical error message:

    Microsoft .NET Framework 4 Setup_20100804_153135034.html

    [8/4/2010, 15:32:21]netfx_Core_x64.msi is now available to install
    [8/4/2010, 15:32:21]Creating new Performer for MSI item
    [8/4/2010, 15:32:21] Action: Performing Action on MSI at C:\63a4819dfa3df0d018f2acf8\netfx_Core_x64.msi...
    [8/4/2010, 15:32:21]Log File C:\Users\FRUELL~1.VPS\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_20100804_153135034-MSI_netfx_Core_x64.msi.txt does not yet exist but may do at Watson upload time
    [8/4/2010, 15:32:21]Calling MsiInstallProduct(C:\63a4819dfa3df0d018f2acf8\netfx_Core_x64.msi, EXTUI=1
    [8/4/2010, 15:32:42] Returning IDOK. INSTALLMESSAGE_ERROR [Auf den Windows Installer-Dienst konnte nicht zugegriffen werden. Dies kann auftreten, wenn der Windows Installer nicht richtig installiert wurde. Wenden Sie sich an den Support, um weitere Unterstützung zu erhalten.]
    [8/4/2010, 15:32:45]MSI (C:\63a4819dfa3df0d018f2acf8\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20100804_153135034-MSI_netfx_Core_x64.msi.txt
    [8/4/2010, 15:32:45]PerformOperation returned 1603 (translates to HRESULT = 0x80070643)

    Microsoft .NET Framework 4 Setup_20100804_153135034-MSI_netfx_Core_x64.msi.txt

    MSI (s) (88:D0) [15:32:42:206]: Note: 1: 1719
    CustomAction SchedSecureObjects_x64 returned actual error code 1601 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (88:D0) [15:32:42:955]: Produkt: Microsoft .NET Framework 4 Client Profile -- Fehler 1719. Auf den Windows Installer-Dienst konnte nicht zugegriffen werden. Dies kann auftreten, wenn der Windows Installer nicht richtig installiert wurde. Wenden Sie sich an den Support, um weitere Unterstützung zu erhalten.

    Based on the error message, it can be translated into English as "The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed".

    It seems that some cause blocks the Windows Installer Service.

    Firstly, please make sure that you're only running one setup at one time.

    Then please check that the Windows Installer service is set to manual but not disable via the following steps:

    1. Click Start, click Run, type services.msc in the Open text box, and then click OK.
    2. In the Services (Local) list, right-click Windows Installer, and then click Properties.
    3. If the Startup type drop-down list is set to a value of Disable, select the Manual option from the Startup type drop-down list, and then click OK.
    4. Click the File menu, and then click Exit.

    If it's already set right, try to repair Windows Installer:

    1. Run regedit (Start > Run > Regedit)
    2. Go to the location
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\msiserver
    3. Right click on this key and select "Export" to save the backup .reg file for late use
    4. Open an elevated command prompt. To do this, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.
    5. Type the following command, and then press ENTER:
      sfc /scannow
      Do not reboot when complete
    6. Double click saved .reg file from working machine and import registry
      settings into Windows 7.
    7. Reboot

    For more information about System File Checker tool (SFC.exe) usage, please see: http://support.microsoft.com/kb/929833
    For more detail steps to repair Windows Installer, please see: http://www.winhelponline.com/blog/vista-the-windows-installer-service-could-not-be-accessed/.

    And re-registering the Windows Installer service by typing "msiexec /unregister" and then "msiexec /regserver" in the command prompt.
    Also, the System account should have "Full Control" permissions to the HKEY_CLASSES_ROOT hive of the registry.

    If no avail, I would suggest you to upgrade Windows Installer to the latest Version 4.5.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen

    (This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.)


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Monday, August 16, 2010 2:58 AM
    Friday, August 6, 2010 12:20 PM

All replies

  • Hi Fruell,

    Thank you for your email and log files.

    For error code "0x80070643", it's a common message that means "fatal error during installation".

    I've checked your log files and found the following critical error message:

    Microsoft .NET Framework 4 Setup_20100804_153135034.html

    [8/4/2010, 15:32:21]netfx_Core_x64.msi is now available to install
    [8/4/2010, 15:32:21]Creating new Performer for MSI item
    [8/4/2010, 15:32:21] Action: Performing Action on MSI at C:\63a4819dfa3df0d018f2acf8\netfx_Core_x64.msi...
    [8/4/2010, 15:32:21]Log File C:\Users\FRUELL~1.VPS\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_20100804_153135034-MSI_netfx_Core_x64.msi.txt does not yet exist but may do at Watson upload time
    [8/4/2010, 15:32:21]Calling MsiInstallProduct(C:\63a4819dfa3df0d018f2acf8\netfx_Core_x64.msi, EXTUI=1
    [8/4/2010, 15:32:42] Returning IDOK. INSTALLMESSAGE_ERROR [Auf den Windows Installer-Dienst konnte nicht zugegriffen werden. Dies kann auftreten, wenn der Windows Installer nicht richtig installiert wurde. Wenden Sie sich an den Support, um weitere Unterstützung zu erhalten.]
    [8/4/2010, 15:32:45]MSI (C:\63a4819dfa3df0d018f2acf8\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20100804_153135034-MSI_netfx_Core_x64.msi.txt
    [8/4/2010, 15:32:45]PerformOperation returned 1603 (translates to HRESULT = 0x80070643)

    Microsoft .NET Framework 4 Setup_20100804_153135034-MSI_netfx_Core_x64.msi.txt

    MSI (s) (88:D0) [15:32:42:206]: Note: 1: 1719
    CustomAction SchedSecureObjects_x64 returned actual error code 1601 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (88:D0) [15:32:42:955]: Produkt: Microsoft .NET Framework 4 Client Profile -- Fehler 1719. Auf den Windows Installer-Dienst konnte nicht zugegriffen werden. Dies kann auftreten, wenn der Windows Installer nicht richtig installiert wurde. Wenden Sie sich an den Support, um weitere Unterstützung zu erhalten.

    Based on the error message, it can be translated into English as "The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed".

    It seems that some cause blocks the Windows Installer Service.

    Firstly, please make sure that you're only running one setup at one time.

    Then please check that the Windows Installer service is set to manual but not disable via the following steps:

    1. Click Start, click Run, type services.msc in the Open text box, and then click OK.
    2. In the Services (Local) list, right-click Windows Installer, and then click Properties.
    3. If the Startup type drop-down list is set to a value of Disable, select the Manual option from the Startup type drop-down list, and then click OK.
    4. Click the File menu, and then click Exit.

    If it's already set right, try to repair Windows Installer:

    1. Run regedit (Start > Run > Regedit)
    2. Go to the location
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\msiserver
    3. Right click on this key and select "Export" to save the backup .reg file for late use
    4. Open an elevated command prompt. To do this, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.
    5. Type the following command, and then press ENTER:
      sfc /scannow
      Do not reboot when complete
    6. Double click saved .reg file from working machine and import registry
      settings into Windows 7.
    7. Reboot

    For more information about System File Checker tool (SFC.exe) usage, please see: http://support.microsoft.com/kb/929833
    For more detail steps to repair Windows Installer, please see: http://www.winhelponline.com/blog/vista-the-windows-installer-service-could-not-be-accessed/.

    And re-registering the Windows Installer service by typing "msiexec /unregister" and then "msiexec /regserver" in the command prompt.
    Also, the System account should have "Full Control" permissions to the HKEY_CLASSES_ROOT hive of the registry.

    If no avail, I would suggest you to upgrade Windows Installer to the latest Version 4.5.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen

    (This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.)


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Monday, August 16, 2010 2:58 AM
    Friday, August 6, 2010 12:20 PM
  • Hi Fruell,

    I'm writing to follow up the post. Does the above suggestion work?

    Please feel free to let me know if you need any help.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, August 12, 2010 8:28 AM
  • Hi Fruell,

    I've marked my reply as answer. If you have any concern, please feel free to let me know.

    Have a nice week!

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, August 16, 2010 2:58 AM
  • Hi YiChun,

    i have make all steps on our instruction but the problem seems to be the same.
    I can also not Update the Windows installer for version 4.5 this is not the right version for Windows 7.
    Have you another idea what to do.

     

    Best regards Friedhelm

    Wednesday, October 13, 2010 1:51 AM
  • I had the same problem.  When I looked at the log it said it was having problems with "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\SetupCache\Client\netfx_Core_x64.msi".  I ran that file path from a command prompt (with no parameters) and it did not throw any erros.  I then tried uninstalling again (from "add/remove programs") and it worked.  I dont know if any of the rest of the things I did contributed to this working but here are the things I did:

    - Uninstalled all the other .NET Framework 4 versions I had installed (extended and multi-targeting)

    - Uninstalled and re-installed the 64 bit Visual C++ Redistributable

    - Tried "repairing" the .net framework 4 client profile (failed)

    - Tried "removing" the .net frameworkd 4 client profile (failed)

    Monday, January 31, 2011 7:51 PM
  • Hi Yichun,

    I have a similar issue and i follwed all the steps. When i tried to run the sfc/scannow command on command prompt, it returned following error:

    "Windows Resource Protection could not start the repair service."

    Can you adivse some solution for this?

    --Usman

    Tuesday, March 20, 2012 8:52 PM