none
Kinect for Windows hangs PC - USB problems? RRS feed

  • Question

  • I have just received my Kinect for Windows and installed version 1.7 of the SDK and Developer Toolkit. Nearly all the samples hang my PC and some do anything at all. I have read about USB issues so I'm assuming this is USB as well. I have removed all other USB devices and tried all the USB ports. Some work for 5 to 10 seconds before hanging, other ports just hang immediately.

    I have noticed though that if a single stream is active the Kinect works (colour or depth), but when both streams are on the heng occurs and I either need to reboot the PC or pull the Kinect USB connection.

    On those that don't do anything I have taken the Greenscreen demo sample as an example. In the code I have noticed that there is a synchronization between the color and depth stream and this must be within half a frame. On my system these streams are so far out synchronization never occurs and therefore it appears the application does nothing.

    I have a very high end PC, custom built:

     - Asus Z9PE-D8 WS motherboard

     - Dial XEON 8-core processors running at 3.2 GHz (total of 16 physical cores, 32 virtual cores)

      - 64 GByte RAM, Quadro 4000 card with a Tesla GPU processor (C2075)

      - Windows 7 - 64 bit

    I'm obviously very stuck and I can do no development whatsoever (the synchronization is a big deal for me in my application).

    Nicole Dolder

    Sunday, June 23, 2013 9:37 PM

All replies

  • What do you mean by hang? Is the application unresponsive or there is no data that is being parsed and therefore the images are not updating? Based on the single stream behavior, it seems like it may be bandwidth availability for the USB port. Can you try the device on another system to rule out the sensor as an issue?

    Please post the specifics of your system, down to the chipset and driver versions. Are you using any of the known USB devices that are known to have issues? As you are aware from your research on these issues, you must be plugged into a USB2 host controller that is not shared with other devices.

    http://msdn.microsoft.com/en-us/library/dn188692.aspx

    In Device Manger, you can view your "Devices by connection" and drill down for your "Host Controller" the Kinect is connected to. On the Generic USB Hub properties, in the tree, you can get Power and Advanced properties for the BW Consumed Value.

    Monday, June 24, 2013 6:17 PM
  • I've been fiddling around and I now get the Kinect to work "sometimes", but more often than not it hangs the PC or the stream is very jerky. I'm using the Kinect Explore D2D sample application as a reference.

    I have made sure the Kinect is plugged into it's own unique USB hub. The PC has a number of USB 2.0 connections and a number of USB 3.0 ones. The Kinect is on a 2.0 port. The USB 2.0 is part of the Intel C602 chipset and is driven by the standard Microsoft USB driver (the 3.0 is a different chipset with an ASUS driver). On the properties of the USB Hub the Kinect draws a power of 16mA from 500mA available, high speed mode. The Advanced tab with the BW never shows anything.

    When I run the application most of the time it will run fow a second or two, then freeze the PC for 5 and sometimes more seconds, start again for a fraction of a second, etc... On a number of occasions the PC freezes and does not recover until I pull out the USB cable.

    The strange thing is that if I start and stop the application some 5/6 times the Kinect will work normally. Stopping the application and restarting again will result in the "run/freeze" state again.

    While running I have kept the CPU Performace monitor open (from the Task Manager). When I run the Kiect Studio application all 32 cores reach close to 100% usage!! During the freeze or "hang" the PC is becomes totally unresponsive...mouse and keyboard stops working, UI totally stops updating, even the CPU monitor freezes (no updates). When I got the Kinect to actually work CPU usage was still at the 90% usage for all 32 cores. I checked the NVidia GPU monitor and it is active when the application runs.

    When I use a single stream application from the Kinect the CPU usage is low (i.e. only color or depth).

    Regards,

    Nicole

    Tuesday, June 25, 2013 11:14 AM
  • Do the WPF (non DX samples) work better?
    Thursday, June 27, 2013 4:50 AM
  • I'm having the same problems with the WPF samples.

    I put together a simple application to rule out GPU problems (reads the streams but dumps the data). I didn't get a hang but the results are suspicious:

    1. Color stream only: no problems and CPU usage is very low (a few percent).

    2. Depth stream only: no problems and CPU usage is very low.

    3. Color + depth: no problems and CPU usage remained low.

    4. Skeleton stream only: runs but CPU usage is VERY HIGH!!! All cores 60% and above and a few even hit the 100%

    5. All streams enabled: runs but CPU sits between 60% and 80% with some cores reaching 100%

    As a reminder I have a very high end PC with 32 cores (16 physical cores). It is apparent from (5) that the PC has no bandwidth left to handle the Kinect and UI.

    Do I maybe have a faulty Kinect? It is coming up to a week old so I could still exchange it if need be (bought from Microsoft).

    Nicole

    Thursday, June 27, 2013 3:12 PM
  • does the Skeleton Basics WPF sample peg the CPU as well?
    Saturday, June 29, 2013 2:39 AM
  • Yes, all samples which use the skeleton peg the CPU.

    Further testing with the sample I created (only reads the streams...no UI) will also sometimes completely peg the CPU resulting in the PC no longer responding. The strange thing is that is I start the test and the CPU usage hovers for example around the 80%, then while the test runs it will remain around this level. Again, if the test starts and the CPU is stuck in the high 90's, it will remain at this level until the test stops.

    I'm going to modify one of the sample apps and play around with the processor affinity (number of cores used) to see if this makes a difference. I'll post the results.

    Nicole

    Saturday, June 29, 2013 12:17 PM
  • ok, thanks!
    Sunday, June 30, 2013 12:55 AM
  • also, have you tried different USB ports/host controllers?
    Sunday, June 30, 2013 1:17 AM