none
How do I prevent Outlook for iOS from stripping special characters? RRS feed

  • Question

  • We have seen a recent problem where our timecard approval emails are not working when the manager "approves" them.

    The source email comes from Oracle timekeeping and it includes an "Approve" and "Reject" hyperlink that forwards the timesheet ID and approval instruction to an email address using the MAILTO feature.  In the past, on both Android and iOS, the approval message would appear in Outlook in the inbox.

    The manager would click approve (or reject) and a new email message would open with the MAILTO target being the system mailbox that handles timecard approvals.  In the body of the popup message would be some text containing [] braces.  For example, it would include in the body text like this:

    ID[1234567890]

    In a recent update, we assume, that functionality has stopped working in iOS only.  Now, the Outlook pops up a message that looks like this:

    ID1234567890 without the braces.

    In the email's VIEW SOURCE readout, the braces are present.  So, the issue is surfacing when the Outlook transfers the properly formatted ID number from the email into the new popup MAILTO email.  That is when the special characters are being stripped, when they were not previously.

    This breaks the downstream email handler.  So, my question is, how do I prevent Outlook for iOS from stripping special characters?  Is there a configuration setting that handles MAILTO special character encoding? 

    Thanks.

    Tuesday, December 10, 2019 2:16 PM

All replies