none
VBA editor - Project explorer Error RRS feed

  • Question

  • I prepared a new machine:

    Lenovo ThingStation P330, Windows 10 1809, Office 2019 32 bit, latest updates installed.

    In all Office applications the VBA doesn't work. Project explorer shows nothing or nonsense. It's not possible to save VBA code within a document.

    I did some new installations (including Windows) with other Office versions -> the same result!

    Is there a known issue (probably with Win 1809)? Any ideas?

    Thx Reinhard

    Sunday, January 20, 2019 10:45 PM

Answers

All replies

  • Is the Developer Ribbon Tab displayed in the worksheets?

    I personally did not think it needed to be displayed but my interpretation of the info at the following link indicates that maybe it does need to be displayed.

    https://support.office.com/en-us/article/show-the-developer-tab-e1192344-5e56-4d45-931b-e5fd9bea2d45


    Regards, OssieMac

    Monday, January 21, 2019 4:41 AM
  • I'm talking about the VBA editor not Excel/Word/… ribbon interface.

    Project explorer doesn't show workbook's object structure. It's not possible to save any code. Very strange, never had this before. It's after a new installation (black computer) of Win 1809 and Office 2019. On my old machine, on which I run Win 1809 as well is no problem. Very strange behavior.

    Any ideas?

    Monday, January 21, 2019 7:29 AM
  • I realize that it is the VBA Editor that you are having the problem with.

    However, as per my previous post, my interpretation of the guidelines in the link I gave you, indicates that the Developer ribbon needs to be displayed if you want to perform any of the 8 dot points below the first paragraph so my question to you "Is the Developer ribbon displayed?"

    If the Developer ribbon is displayed then unfortunately I don't know the answer to your problem.


    Regards, OssieMac

    Monday, January 21, 2019 8:58 AM
  • The only two settings I can think of that would prevent you saving is if in Trust Center macros are disabled entirely, or if Save is disabled for macro or binary workbooks under File Block Settings.

    You say you can't save - after editing code can you save in Excel and / or with code

    Thisworkbook.Saveas "test.xlsm", 52

    What else can and can't you do in the VBE?

    Monday, January 21, 2019 9:40 AM
    Moderator
  • What I did:

    1. Made Developer tab visible in ribbon bar

    2. Options - Trust Center Settings - Macro Settings - Enable all macros + Trust access to the VBA ...

    When I start Excel with a Blank workbook and press Alt+F11 the following will come up.


    Monday, January 21, 2019 1:44 PM
  • Amazing, it has to do with Windows 1809.

    When I'm using Windows 1803 it works.

    No idea, why a clean Windows 1809 installation corrupts VBA?

    Thx

    • Marked as answer by reinht Monday, January 21, 2019 9:47 PM
    • Unmarked as answer by reinht Monday, January 21, 2019 9:47 PM
    Monday, January 21, 2019 6:33 PM
  • Suggest that you try the following link for support. (DON'T click the button "Open Get Help app" but select the "Contact support" link  under the button)

    https://support.microsoft.com/en-au/contactus/


    Regards, OssieMac

    Monday, January 21, 2019 10:31 PM
  • The following answer confirms the problem but brings no solution.

    Unable to run Excel VBA 'record macro' in Office 2016

    Lot's of problems with Windows 1809!

    Thx Reinhard 

    Monday, January 21, 2019 11:24 PM
  • I have Microsoft Office 365 Business Version 1812 Build 11126.20266.  I don't have any problems.
    Tuesday, January 22, 2019 1:24 AM
  • Unfortunately, Office 365 is no solution, because the macro has to be run on older Office versions as well.

    Looks like Windows 1809 is the problem, because no problem with Windows 1803 and all Office versions.

    Any workaround, apart Windows 1803 (update philosophy)?

    Thx, Reinhard


    Tuesday, January 22, 2019 7:55 AM
  • This looks like a major issue. I don't have 1809 yet, and as far as I can see the only way to avoid getting it is disconnect from the internet! 
    Tuesday, January 22, 2019 9:18 AM
    Moderator
  • I have no problem.  Setup:

    Microsoft Office 365 Business Version 1812 Build 11126.20266

    Microsoft Office 2010

    Windows 10 Home 1809, Build 17763.253

    I have admin rights.

    Tuesday, January 22, 2019 1:11 PM
  • "I have no problem"

    That's good to hear!

    Maybe you (mogulman52) and reinht could compare your respective setups in more detail...?

    Tuesday, January 22, 2019 2:02 PM
    Moderator
  • I bought a new computer and did a clean Windows installation. The following configuration causes the problem:

    - Lenovo ThínkStation P330

    - Windows 10 Enterprise, Version 1809 Build 17763.292 (clean installation)

    - Office 2019, Version 1812 Build 11126.20266

    No problems with Windows 1803 (same computer, clean installation too)

    It looks like that the problem mainly occurs on a fresh, clean installation. Some updated systems don't run into this problem.

    Any ideas?


    • Edited by reinht Tuesday, January 22, 2019 7:51 PM
    Tuesday, January 22, 2019 4:26 PM
    • Marked as answer by reinht Friday, February 1, 2019 5:58 PM
    Friday, February 1, 2019 5:58 PM