none
Can't install Kinect for Windows and SDK etc RRS feed

  • Question

  • Hi!

    Got myself a kinect camera today, quite exited first but... can't get it to work. If i plug it in.. it shows that my PC does not recognize the hardware which are connected, drivers are not found and i get that plugged in-plugged out windows alert sound from speakers. Device manager does not show up. Green LED is flasing. I've been checking the power and usb cables already - they are fine.

    If i downloaded SDK (as far as i understand i should contain all the drivers and etc?) and try to run it.. it simply stops. No visible errors or anything. I tried to Install Develop Toolkit as well but same thing. No execution, no error - no installation progress whatsoever - program just don't do anything. Yes, i've tried to run it as and Admin. - nothing.i'm working on win7 ultimate and i7 and i5 workstations which has enough power to handle kinect.

    I've tried to load previous SDK versions and even tried Runtime and so on.. same result - nothing.

    Aand.. finally.. i've tried to do same steps on 3 different machines. My day is completely wasted and i'm annoyed. I even did a microsoft community account to ask for help.

    Does my computer miss something that is required for installing the device or what?

    Thanks in advance

    Rauno



    • Edited by RaunoS Thursday, October 10, 2013 6:34 PM
    Thursday, October 10, 2013 6:21 PM

Answers

All replies

  • OK, solution was to disable UAC. I'm kind of surprised that UAC has to turn off if u are trying to install microsoft's product.. but it did the trick.

    Friday, October 11, 2013 8:02 AM
  • You shouldn't have to turn off UAC. There may be other security or group policies that were applied to your machine that effect the permissions of the installer to put files where they need to be. Check your Setup logs in the temp folder to determine what happened during the failed attempts to install.

    Carmine Sirignano - MSFT

    Monday, October 14, 2013 7:38 PM
  • Hi Carmine,

    I have the same problem. Windows 8.1 x64. Kinect for Windows. Connecting the Kinect for Windows causes the following sequence:

    1. device connection sound

    2. wait a minute or so

    3. device disconnection sound

    4. go to 1

    In Device Manager I can see the Kinect camera and microphone appear under 'Other devices', but no drivers are found.

    The setup log ends like this:

    [2280:2BA4][2013-10-17T10:55:06]: Apply begin
    [258C:0A98][2013-10-17T10:55:06]: Caching executable from: 'C:\Users\Peter\Downloads\Kinect\KinectSDK-v1.8-Setup.exe' to: 'C:\ProgramData\Package Cache\{5f9eeaf3-984f-46b4-84f9-e8e1d5b255a8}\KinectSDK-v1.8-Setup.exe'
    [258C:0A98][2013-10-17T10:55:06]: Registering bundle dependency key: {5f9eeaf3-984f-46b4-84f9-e8e1d5b255a8}, version 1.8.0.595
    [2280:2B20][2013-10-17T10:55:06]: Error 0x80004005: Failed to extract all files from container.
    [2280:26A4][2013-10-17T10:55:06]: Error 0x80004005: Faild to begin and wait for operation.
    [2280:26A4][2013-10-17T10:55:06]: Error 0x80004005: Failed to extract payload: a9 from container: WixAttachedContainer
    [2280:26A4][2013-10-17T10:55:06]: Failed to extract payloads from container: WixAttachedContainer to working path: (null), error: 0x80004005.
    [2280:26A4][2013-10-17T10:55:06]: Error 0x80004005: Failed to cache packages.
    [2280:2BA4][2013-10-17T10:55:06]: Error 0x80004005: Failed while waiting for cache thread to complete before executing.
    [258C:0A98][2013-10-17T10:55:06]: Removing bundle dependency key: {5f9eeaf3-984f-46b4-84f9-e8e1d5b255a8}
    [258C:0A98][2013-10-17T10:55:06]: Removing cached bundle: {5f9eeaf3-984f-46b4-84f9-e8e1d5b255a8}, from path: C:\ProgramData\Package Cache\{5f9eeaf3-984f-46b4-84f9-e8e1d5b255a8}\
    [2280:2BA4][2013-10-17T10:55:06]: Apply complete, result: 0x80004005 restart: No

    I have downloaded KinectSDK-v1.8-Setup.exe with Chrome, IE and Firefox. All files are the same size (77 178 601 bytes), and identical. No proxy cache except possibly a transparent one at the ISP. I have run the executable from Windows Explorer, a command prompt, and an administrator command prompt. All generate the same result.

    Any suggestions would be appreciated.


    Thursday, October 17, 2013 9:08 AM
  • It seems your KinectSDK-v1.8-Setup.exe download are corrupted. The size should be ~222.4MB.

    Be sure to download it from here http://www.microsoft.com/en-us/download/details.aspx?id=40278 


    Vincent Guigui Innovative Technologies Expert at OCTO Technology MVP Kinect

    Thursday, October 17, 2013 9:45 AM
  • Disabling UAC had no effect.
    Thursday, October 17, 2013 10:03 AM
  • As Vincent stated, your files seem to be corrupt given they are not the correct size. http://www.microsoft.com/en-us/kinectforwindowsdev/Start.aspx

    You may have some caching issues in the browser, or as you stated something at the ISP. Are you using the save to computer option when downloading?


    Carmine Sirignano - MSFT

    Thursday, October 17, 2013 10:49 PM
  • Yes, it seems it was corrupt. All good now. Thanks!
    Friday, October 18, 2013 4:31 AM